Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

01 HD2500 starting problem

Discussion in '1992-Present Chevy & GMC models' started by perp, Aug 5, 2005.

  1. perp

    perp 1/2 ton status

    Joined:
    Jul 14, 2005
    Posts:
    569
    Likes Received:
    0
    Location:
    Chandler AZ
    i did a search but didn;t find anything close. so here is the problem:
    the truck is a 2001 HD 2500 with a 6.0.
    in the begining,If i get in and just turn the key it will crank over forever and not start. if i let off andcrank again same thing happens. but if i turn key back to off for a few seconds and recrank it starts
    after a few months of this it got worse. from a cold truck, i then had to turn the key to run and watch the temp guage, it would go to max temp for a few seconds, then return to the cold side of gauge. after it came down i could turn kew off and then start it just fine. if i didn't do this and just turned key, it would still crank forever with out starting, BUT if i turned key to run and the guage went up and i turned back to off and started engine before the guage came down the thing would run around 250 Rpm and shake bad and the message center in the dash would show engine overheat. put it in gear and it tries to die. if i turn it off and let it sit 2 or so minutes, then go though the how mess of turning the key on and wiating for the temp guage to do its thing, it restarts fine. the truck runs perfect otherwise. oh, and this problem is much worse when it is cold outside. 65k miles, out of warranty. anyone else have this kind of issue?
     
  2. 88sub4x4

    88sub4x4 1/2 ton status

    Joined:
    Sep 22, 2002
    Posts:
    792
    Likes Received:
    0
    Location:
    Long Island, NY
    Sounds like a bad coolant temp sensor to me. They are pretty cheap. If the computer sees that the truck is warm, instead of cold, it won't supply enought fuel for the cold engine to start, and if it does happen to start it will run real crappy since it will be lean. After a couple of minutes though the computer will figure out the fuel needs by way of other sensors and the truck will run fine. This will not always throw a fault code either.
     
  3. perp

    perp 1/2 ton status

    Joined:
    Jul 14, 2005
    Posts:
    569
    Likes Received:
    0
    Location:
    Chandler AZ
    thanks, i'll try replacing that.
     
  4. 88sub4x4

    88sub4x4 1/2 ton status

    Joined:
    Sep 22, 2002
    Posts:
    792
    Likes Received:
    0
    Location:
    Long Island, NY
    Any updates on this? Did you get it figured out?
     
  5. perp

    perp 1/2 ton status

    Joined:
    Jul 14, 2005
    Posts:
    569
    Likes Received:
    0
    Location:
    Chandler AZ
    Sorry, haven't tried anything yet. I hve been super busy, my waterbed exploded and so i have been remodeling my bedroon as the water damage was bad. I will post as soon as i try anything, thanks for the interest.
     
  6. 88sub4x4

    88sub4x4 1/2 ton status

    Joined:
    Sep 22, 2002
    Posts:
    792
    Likes Received:
    0
    Location:
    Long Island, NY
    I'm not going to ask what was going on when it exploded! :eek1: :D
     
  7. perp

    perp 1/2 ton status

    Joined:
    Jul 14, 2005
    Posts:
    569
    Likes Received:
    0
    Location:
    Chandler AZ
    :whistle: .................. :woot: :woot: :woot: ................. :waytogo:
     

Share This Page