Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

10b front gurus.....question (UPDATE)

Discussion in 'The Garage' started by MTBLAZER89, Jun 23, 2003.

  1. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    UPDATE: I installed the hubs with no little snap rings. I read in previous posts that this was ok.....Is It?????

    Got my Fawkin steering arm off finally... /forums/images/graemlins/thumb.gif.



    Ok I put my new axle under my K5 today. It's from an 82 K20..8 Lug 10b. Everything is under my truck, and I started puting my hubs on. There is no groove for the "little" snap ring at the end of the axle. There is a groove right after the outer locknut. Anyway I put it there and everythig went together ok until I put the big snap ring in. Now it's in, but it's really tight I don't know how to get it out. When I put the hub cap on there is like a 1/32nd gap. Everything works ok, but I am sure it's not right. Anyway sorry so long just wanted to get all the details.

    1. Is that the correct location for the "little" snap ring?
    2. If I can get this apart /forums/images/graemlins/confused.gif (anybody have a tip on this?) do I have to keep that little snap ring?
    3. Why doesn't this axle have the groove for the snap ring?
    4. How the hell do I get the steering arm off? I broke a 10lb sledge today /forums/images/graemlins/eek.gif.

    Thanks
     
  2. Sinful_Nature

    Sinful_Nature Registered Member

    Joined:
    Jun 14, 2002
    Posts:
    90
    Likes Received:
    0
    Location:
    Raymond, NH
    Re: Ok please help I am stuck...Hub/axle question.

    This sounds like a problem I had with my stock 10 bolt, when I went to Warn Manual Hubs, what type of hubs do you have? With the warn hubs they were very tight against the snap ring (which was a "B" to remove) and the cap was a little lose. Althought I didn't like it, Warn and a few other guys stated this was "ok".

    I don't have this issue with my dana 44 and warn hubs.

    As for the steering arm, good luck! I've never done one, a friend of mine knows a "serect" to removing them, which he won't share with us. /forums/images/graemlins/frown.gif (I think he likes the reward after lol) Let me know if you still need help and I'll see if I can get some info.
     
  3. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Ok please help I am stuck...Hub/axle question.

    Yeah they are Warns. These hubs were in a 10b. I am just putting them in an 8 lug 10b from an 82 K20. I really don't understand whats the difference.
     
  4. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Ok please help I am stuck...10 bolt Hub/axle question.

    ttt
     
  5. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Ok please help I am stuck...10 bolt Hub/axle question.

    update
     
  6. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Ok please help I am stuck...10 bolt Hub/axle question.

    /forums/images/graemlins/confused.gifPlease help........... /forums/images/graemlins/ears.gif........anyone know somebody I can PM about this at least??
     
  7. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,188
    Likes Received:
    1,396
    Location:
    E-town baby!
    Re: Ok please help I am stuck...10 bolt Hub/axle question.

    The little snap ring would most likely be for the old Spicer hubs which need it. So you're prolly OK without it using the Warns.

    The steering arm can be a beotch, but there is a method that works. The last one I did took all of 3 minutes.

    Hit down on the arm and side to side...not up whatever you do. Under the nuts are tapered and barbed cone washers, if you hit upwards it just seats the cone washers tighter. Hit side to side and down on the arm and you'll see the washers loosen a little. As soon as you see one loosen use some needle nose or smaller channel lock pliers to try and pick it out or rotate is out like a nut. It's wise to leave the steering arm nuts on the studs right at the top of the studs to protect the stud end from any stray hammer damage.

    Soaking the whole works with PB blaster helps, and so does a bit of heat if it's really tough. I used a 2 lbs ball pien hammer and it wasn't a big deal though.

    Rene
     
  8. MTBLAZER89

    MTBLAZER89 3/4 ton status GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Ok please help I am stuck...10 bolt Hub/axle question.

    Thanks Rene. Any idea why one axle has the groove and the other one doesn't?? /forums/images/graemlins/thinking.gif
     

Share This Page