Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

16x10 rims are rubbing

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by midnitlove, Sep 5, 2001.

  1. midnitlove

    midnitlove Registered Member

    Joined:
    Mar 19, 2001
    Posts:
    53
    Likes Received:
    0
    Location:
    Orange County, California
    I just bought American Eagle 16x10 rims and put 35in boggers on them and after mounting them and driving the rims don't seem to have enough backspacing. they rub on my steering bar ball joints. anyone else have this problem. what would be the solution. Spacers?? What kind of rims will give another inch or so.

    thanks.

    <font color=red> AMIGOS SO. CAL </font color=red>
     
  2. travis

    travis 1/2 ton status

    Joined:
    Nov 17, 2000
    Posts:
    173
    Likes Received:
    0
    Location:
    Panama City, FL
    I feel your pain. I bought the exact set to go with my 35" Claws. The back spacing is 4.5 inches. You need less than 4 inches to work properly. I was going to buy wheel spacers from Performance Wheel (1 inch for the front and 2.5 inches for the back). It would have made everything sit evenly but I couldn't justify spending $300 for spacers. I ended up selling my entire set-up. If you do the research you can find some 16x8 rims with the proper back spacing. I think Mickey Thompson Classic II's are the correct size. I know it's a bummer. The 16x10s you have are designed for late model chevys.

    Travis
     

Share This Page