Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

1989 c1500, heater system issues

Discussion in 'The Garage' started by R72K5, Nov 25, 2004.

  1. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    ok a friend of mine has an old 89 c1500 pickup

    his heater system is all wacked up

    there is heat in the base of the heater boxes at the firewall

    the engine seemingly takes a long time to heat up never seems to get over 150 degrees on aftermarket guage

    the only air that blows out of the heater system very good is the base vents for floor over center tranny tunnel,

    defrost barely puts out any air, you can barely feel any air movement at all

    and the dash vents are totally dead cold no movement at all

    the heater controls in dash are those pushbutton 89 style ones to match the radio buttons design and look


    he says its his thermostat stuck open

    but i dunno,,,,

    the heater blower motor sounds VERY strong and you can tell its moving some air, and it does put out good air volume out the floor vents

    and thats it

    never hot unless the engine has been running for a vERY long time but even then its not really hot, just really warm,


    is there a common problem with these trucks that this happens in them ??

    thanks
     
  2. blazerpunk

    blazerpunk 1/2 ton status

    Joined:
    Feb 3, 2004
    Posts:
    121
    Likes Received:
    0
    Location:
    Trinidad, CO
    Thermostat is stuck open. If he hooked up the after market temp gauge to the thermostat houseing make sure the sensor isn't to long. PO on my blazer put one in that was to long and pushed open the thermostat. when I swaped to a 4 core rad. it wouldn't even register on the gauge, before it would never get over 160. /forums/images/graemlins/thumb.gif
     
  3. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    interesting

    he bought the truck how it is, the guages were already installed

    any other things to check ?

    thanks
     
  4. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    nope the thermostat housing is late model 4.3 style and oes not have any threaded holes or anything in it, the temp sensor goes in pass side head in between front two cylinders

    checked heater core todaay, hot coolant is not going through the core, its plugged,

    and engine doesnt get over 160 ever

    and theres still problem of no air to defroster and dash vents ever
    can hear positions change int eh dash however

    just no air at all, cold or warm, nothing

    sometimes is a tiny bit of air out defrost, but barely enough to notice

    thanks
     

Share This Page