Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

1990 Jimmy TBI won't start, please HELP!

Discussion in 'The Garage' started by backinblack, Sep 12, 2003.

  1. backinblack

    backinblack Banned

    Joined:
    Sep 9, 2003
    Posts:
    5
    Likes Received:
    0
    1990 Jimmy TBI won\'t start, please HELP!

    It's got 113,000 miles (supposedly). Started and ran perfectly up until yesterday w/ minor puff of smoke for 1 second when cold. Today it turns over fine but no hint of starting. I had my brother crank it while I looked at the injectors and saw no fuel, Should I? I will check the fuel filter but was wondering if it could be anything else simple. Any help would be greatly appreciated. P.S. I am new to Fuel Injection.
     
  2. heavy4x4

    heavy4x4 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    3,270
    Likes Received:
    0
    Location:
    Delafield, Wisconsin
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Yes, you should see gas coming out of the injectors as the engine cranks. Replace the fuel filter to begin with. If that doesn't do it (probably won't), your fuel pump has kicked the can and needs replacing. If you replace the pump, make sure you replace the filter too.
     
  3. backinblack

    backinblack Banned

    Joined:
    Sep 9, 2003
    Posts:
    5
    Likes Received:
    0
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Forgot to say i can hear the pump run when I switch the key on. Could it still be dead?
    Thanks - Justin
     
  4. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Check for spark. The module in the distributor sends a signal to the ECM, telling it when to fire the injectors. If that signal doesn't go out, the injectors won't fire.
     
  5. backinblack

    backinblack Banned

    Joined:
    Sep 9, 2003
    Posts:
    5
    Likes Received:
    0
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Thank you all, I will check those items out tomorrow... er, I guess it's today now, huh?
     
  6. jpaitala

    jpaitala Registered Member

    Joined:
    Sep 1, 2003
    Posts:
    33
    Likes Received:
    0
    Location:
    Imatra, Finland
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    I had this same problem with my '89 Chevy Van... All the symptoms were the same as you have!!
    The problem was that the ECM did not get any current, it should get 12V when key on run position. I just replaced the "broken" wire to ECM and it ran again...
    Check if the ECM gets current when on run position, if not then that's your problem.

    Good luck.
     
  7. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    same symptoms, cept my engine would kick over twice (by sound) and injectors fire once, twice over, one fire, ended up being temp sensor was dead. $20 sensor after changin distributor cap, rotor, ign module, fuel filter, other stuff that ive 4gotten.
     
  8. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,584
    Likes Received:
    945
    Location:
    Massachussetts
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    If its a v-6 s-10 jimmy,we replace a lot of ignition modules,they control the firing pulse for the injectors as well as the ignition--I've seen modules that still make spark,but dont fire the injectors.(this applies to V8's too)Also see many that work perfect one day and wont start the next,especially when a large temparature or weather change occurs.If yours has a coil pack(3 separate coils for the 6 cylinders)we see a lot of bad or cracked coils also--on the 4.3 motors we have seen a lot of problems with peices of carbon breaking loose and getting stuck in the egr valve port,holding it open and causing stalling,poor idle,no start.Also the "spider" fuel injection distribution tube under the intake has its share of problems too,but usually causes rough running or missing,not a no-start condition(good thing for you cause they cost 400bucks! /forums/images/graemlins/eek.gif /forums/images/graemlins/eek.gif)
     
  9. backinblack

    backinblack Banned

    Joined:
    Sep 9, 2003
    Posts:
    5
    Likes Received:
    0
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Sorry I forgot to clarify it's a full size - stock TBI 350. Haven't had much time to mess with it yet but I checked for spark and there was none. I should probably start with the coil, no? If that doesn't do it what's next? Thanks in advance - Justin
     
  10. Emmettology 101

    Emmettology 101 3/4 ton status

    Joined:
    May 9, 2000
    Posts:
    8,126
    Likes Received:
    0
    Location:
    FL
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Yes, swap out the module in the disty. That SHOULD do it. If not, change the upper oil pressure sending unit(by the disty)..
     
  11. Shagnaz

    Shagnaz 1/2 ton status

    Joined:
    Jul 19, 2002
    Posts:
    308
    Likes Received:
    0
    Location:
    South Carolina, North Charleston
    Re: 1990 Jimmy TBI won\'t start, please HELP!

    Try shooting some carb cleaner down the ports. This will help see if you are getting spark. Mine did the same thing and it ended up being the fuel pump. But, I couldn't hear it.
    Do you have fuel in the tank?
     

Share This Page