Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

1990 K5 Starting Problems-Need Help

Discussion in 'The Garage' started by larryboz, May 9, 2006.

  1. larryboz

    larryboz Registered Member

    Joined:
    Jun 3, 2001
    Posts:
    89
    Likes Received:
    0
    Location:
    Kansas City, Missouri, USA
    I got a problem can't seem to figure out. I cleaned the K5 up and parked for like 3 months. Went out to start it the other day and battery dead so I jumped it off my truck and drove it around for a while(felt good to drive it again) and then returned home and shut it off. Went out later to pull it back in the garage and turned the key nothing but everything came on radio, lights fan but nothing to the motor. I threw the jumper cables on and nothing still. Thought starter was bad because it was original and made a click every once in while so ireplaced it with a new one and solenoid also. Went to start it same thing got pissed went in drank a beer. Looked through the window and pressed my remote start and it started got in put key turn to on position and then turned it off and truck stopped went to start it again nothing so I hit the remote start and it started. Is it the ignition switch you think? I checked all connections and everything is fine. Any help would gladly be appreciated.

    Larry
    lbosworth@kc.rr.com
     
  2. 88-383

    88-383 1/2 ton status

    Joined:
    Sep 11, 2005
    Posts:
    142
    Likes Received:
    0
    Location:
    Tracy. CA
    Id be looking real close how that remote start got installed if it was me. Up unitll you said that I would've said clean all your grounds and battery terminals.

    But, once you mentioned the remote start still works :(

    Good Luck

    KM
     
  3. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    Ignition switches are mighty cheap, about 12 bucks for the spare I bought just in case mine ever goes haywire.
     
  4. larryboz

    larryboz Registered Member

    Joined:
    Jun 3, 2001
    Posts:
    89
    Likes Received:
    0
    Location:
    Kansas City, Missouri, USA
    Yeah previous owner installed a Commando FM-760 remote start and alarm. I am leading to this being the culprit. I think I will remove the whole thing. I don't use it at all.

    Larry
     
  5. Cmoe

    Cmoe 1/2 ton status

    Joined:
    Feb 19, 2000
    Posts:
    2,884
    Likes Received:
    0
    Location:
    Mesa,AZ
    sounds like you may have a weak relay from your key to the starter.... I would say arm and disarm your alarm, then try to start again. Sounds like a great theft prevention device to me... Remote start and Ignition switch is for accesories and steering wheel lock....
     

Share This Page