Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

1995 C1500 4.3L stalls immediately after starting

Discussion in 'The Garage' started by california, Jul 30, 2006.

  1. california

    california Newbie

    Joined:
    Jul 30, 2006
    Posts:
    1
    Likes Received:
    0
    Location:
    Los Angeles, CA
    I own a 1995 C1500 2wd 4.3L, TBI with 180k miles. The truck ran great for 11 years until last weekend when it decided to start stalling out immediately after starting it. The symptoms are as follows:

    1) The truck starts, the engine catches, revs to about 1500 rpm, and then idles down and dies.
    2) If I give it some gas, the engine will stay started and continue to run pretty smoothly, but very rich.
    3) A specific throttle position no longer seems to correlate to a specific engine speed
    4) If I can manage to get the engine speed to stabilize at the normal idle speed my manipulating the throttle pedal, the engine will stay started until some external force causes a change. While the engine is idling, it runs very rough and very rich.

    I have replaced the MAP sensor to no avail. I tested the throttle position sensor for linearity and it checked out fine.

    I am at a loss for what do with this engine. Any assistance would be greatly appreciated.

    Thanks,
    Jeff
     
  2. BoondocK5

    BoondocK5 1 ton status Author

    Joined:
    May 13, 2006
    Posts:
    10,035
    Likes Received:
    63
    Location:
    Salt Lake City, Utah
    Check your fuel pressure, and see if it stays where it's supposed too, while running.
     

Share This Page