Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

1st GEN K5 Speedo Problems

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ED70K5, Sep 11, 2000.

  1. ED70K5

    ED70K5 1/2 ton status

    Joined:
    Apr 28, 2000
    Posts:
    179
    Likes Received:
    0
    Location:
    Texas, USA
    My speedometer is not working. Where should I start looking?? Do I have to yank out the whole cluster?

    Blazin' in TEXAS!
     
  2. blazer72

    blazer72 1/2 ton status

    Joined:
    Apr 13, 2000
    Posts:
    939
    Likes Received:
    0
    Location:
    KCMO
    No start at the other end undo the speedo cabel from the t-case and spin it with a power drill, haveing some one look at the speedo to see if it working. If it does and its a 50 50 chance it will work then its the speedo drive gear on the out put of the t-case. I fi t does not work then pull the cluster to see if the cabel is ok.

    I understand the jeep thing I drive a BLAZER!!

    Ken
     
  3. ED70K5

    ED70K5 1/2 ton status

    Joined:
    Apr 28, 2000
    Posts:
    179
    Likes Received:
    0
    Location:
    Texas, USA
    The cable is screwed into the back of the speedo! How do I get the cable of the t-case?? I have to go buy a wire brush and get 30 years of grime of the t-case/speedo cable connection first!!

    Blazin' in TEXAS!
     
  4. blazer72

    blazer72 1/2 ton status

    Joined:
    Apr 13, 2000
    Posts:
    939
    Likes Received:
    0
    Location:
    KCMO
    the cabels is atached to the t-case in the same way as the speedo head

    I understand the jeep thing I drive a BLAZER!!

    Ken
     

Share This Page