Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

2.5l 4 cyl dying at idle, runs fine when driving though.

Discussion in 'The Garage' started by dodgedude99, Jun 5, 2005.

  1. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    my sons s10 with the 2.5 4 banger hasnt been the same after he made a trip from chicago to kalamazoo and back.
    it now wont idle by itself. it just sorta sputters and dies.

    the cap, rotor, plugs, wires, fuel filter, air filter, breather, and pcv are all new within the last year.

    before the michigan trip it ran fan.

    any ideas?

    (BTW, i know there is an s10 forum on here, but i doesnt seem like it gets looked at very often.)

    thanks
    shawn
     
  2. velocitiii

    velocitiii Registered Member

    Joined:
    Dec 19, 2003
    Posts:
    54
    Likes Received:
    0
    sounds like the IACV (idle air control valve) isn't doing its job.
     
  3. CyberSniper

    CyberSniper 1/2 ton status Premium Member

    Joined:
    Apr 21, 2003
    Posts:
    2,257
    Likes Received:
    5
    Location:
    Chelsea, MI
    Make sure the EGR valve is closing. If that didn't fix it, I'd try the MAP sensor. I'm willing to bet it's the EGR valve though.
     
  4. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    Thanks Cyber sniper, it ended up being the EGR valve.
    Kinda hard for the valve to close when a piece of it is missing (though i would like to know where that piece ended up at :crazy: ).

    $49.99 at Pepboys, she idles like a champ now.
    Just in time for his buddy to buy it so he can purchase a K5 Blazer :D .
     

Share This Page