Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

2000 Z71 Tranny fried?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 76K5, Apr 21, 2003.

  1. 76K5

    76K5 Registered Member

    Joined:
    Jun 23, 2001
    Posts:
    99
    Likes Received:
    0
    Location:
    North Carolina
    My boss asked me to look at his truk this morning. Its a 2000 Z71 5.3 auto, 75,000 mi. It shifts fine until it gets to third gear, then revs to the moon like its in neutral. It was behaving fine just yesterday. It could be slipping, but most autos I ve ever owned started slipping gradually. Could it be something in the computer? Anybody out there had this problem. Thanks for the help /forums/images/graemlins/truck.gif /forums/images/graemlins/usaflag.gif
     
  2. 87project

    87project Registered Member

    Joined:
    Jul 9, 2002
    Posts:
    98
    Likes Received:
    0
    Location:
    Alabama
    My 87 jimmy (700r4)is in the shop right now getting rebuilt and all I lost was 3rd gear /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif
     
  3. Gary 86 K5

    Gary 86 K5 1/2 ton status

    Joined:
    Oct 7, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    Mentor, OH
    Sounds like a sticking shift solenoid or a problem with the valve body in the trans. I work at a Chevy dealer and we see plenty of trans problems. You would think GM would have figured these out by now, oh well though, keeps me busy! /forums/images/graemlins/cool.gif /forums/images/graemlins/k5.gif
     

Share This Page