Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

2001 2500HD 8.1L engine cough

Discussion in 'The Garage' started by bubbas1ton, Mar 14, 2007.

  1. bubbas1ton

    bubbas1ton Newbie

    Joined:
    Dec 13, 2005
    Posts:
    4
    Likes Received:
    0
    Location:
    Alabama
    Problem. Driving along and the engine suddenly loses power and the battery light comes on, nothing else. The engine doesn't completely shut off, more like you have just abruptly taken your foot off the gas. Almost as quickly, everything picks back up again back to normal. Since only the battery light comes on, we had the battery and charging system checked out but it's good. One suspect is the fuel pump since we had it changed about a year ago so we're going to have it checked out. The only pattern, I use pattern very loosely, we seem to notice is that it seems to occur when the cruise is NOT set and shortly AFTER the cruise has been disengaged.

    Any ideas?
     
  2. ryan22re

    ryan22re 1/2 ton status

    Joined:
    Feb 5, 2005
    Posts:
    3,368
    Likes Received:
    0
    Location:
    Irmo, SC
    Forget the fuel pump, and check all power and ground connections. That means removing them, cleaning them and the reinstalling them. Also, check the connectors at the bottom of all of the fuse panels. They are tightened with a bolt. Loosen bolt, undo connector, reinstall and tighten bolt.

    Also, visually inspect the entire wiring harness.

    That should be a start.
     
  3. bubbas1ton

    bubbas1ton Newbie

    Joined:
    Dec 13, 2005
    Posts:
    4
    Likes Received:
    0
    Location:
    Alabama
    thanks, I'll check it out.
     
  4. IGOR

    IGOR 1/2 ton status Premium Member

    Joined:
    May 16, 2000
    Posts:
    2,303
    Likes Received:
    19
    Location:
    Damascus, OR
    This is classic crank shaft sensor issues.


    I had mine go bad in my 2002 8.1 liter GMC - the battery & check engine light came on, and the truck would start surging - would cut off then start up again - eventually it totally died in the middle of a 4 lane major intersection - I was pretty embarrassed in my BRAND new truck - I would check or replace the crank shaft sensor.

    Not to plug other sites - but http://www.dieselplace.com/forum has a great gas engine section that should help you out.
     
  5. kontradictions

    kontradictions 1/2 ton status

    Joined:
    Jul 14, 2006
    Posts:
    134
    Likes Received:
    0
    Location:
    Southern California
    x2 on the crank shaft sensor.

    Mine did it when i first bought it used last year and i did the same searching around like you are doing now, took it to the dealer and told them to replace that and only that and not to touch another thing and it's been fine since. About $150 to replace at the dealer...
     
  6. Pvt. Maggot

    Pvt. Maggot 1/2 ton status

    Joined:
    Sep 27, 2005
    Posts:
    559
    Likes Received:
    0
    Location:
    Brownsville PA
    X3 on the crank sensor, our 02 hd had the same problem, cutting out, get it changed right away, it will start shutting down completely, it happened to us twice once in a tight turn, and once in an intersection, def get it changed out!
     

Share This Page