Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

350 Tbi Running Real Choppy

Discussion in 'The Garage' started by az ranger, Jul 8, 2006.

  1. az ranger

    az ranger 1/2 ton status

    Joined:
    May 9, 2004
    Posts:
    139
    Likes Received:
    0
    Location:
    Safford AZ
    I changed the fuel filter , checked the spark plugs/wires. But it still running like crap. choppy is the best way I can describe it. it does not ever die or cut out. it just does not power up right. I t feel like it is not getting enough fuel.

    I also turned the key on with the fuel line off at the filter and pumped gas in to a jug to see how it looked. there was some rust sediment in the bottom but not much.

    Could the pump be going bad?

    any other Ideas?

    thanks
     
  2. supersize75k5

    supersize75k5 OrganDonorRacing.com

    Joined:
    Feb 3, 2004
    Posts:
    8,832
    Likes Received:
    4
    Location:
    gilbert az
    get a fuel pressure tester and check the pressure your getting
     
  3. resurrected_jimmy

    resurrected_jimmy 1/2 ton status

    Joined:
    May 23, 2005
    Posts:
    2,241
    Likes Received:
    0
    Location:
    back home in Houston
    if trash got into the injectors they may not be very happy
     
  4. SoonerBob

    SoonerBob Registered Member

    Joined:
    Nov 6, 2005
    Posts:
    20
    Likes Received:
    0
    Location:
    Norman, OK
    my '88 Jimmy is doing the exact same thing. i would love to know what is wrong and how to fix it.
     
  5. supersize75k5

    supersize75k5 OrganDonorRacing.com

    Joined:
    Feb 3, 2004
    Posts:
    8,832
    Likes Received:
    4
    Location:
    gilbert az
    maybe over night your nieghbors overhauled your ride and added a 272 cam...
     
  6. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    Is the ECM tossing out any trouble codes?
     
  7. az ranger

    az ranger 1/2 ton status

    Joined:
    May 9, 2004
    Posts:
    139
    Likes Received:
    0
    Location:
    Safford AZ
    ecm gives EGR and VSS but these have been showing up for along time I dont think it is related. I have a new EGR and and The VSS I think would not be on there if I cleared them and retried. I will do that later.

    keep the ideas coming

    thanks
     
  8. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    Have you hooked up a vacuum gauge to see what the needle shows? That'd be a pretty cheap and easy check.
     
  9. SoonerBob

    SoonerBob Registered Member

    Joined:
    Nov 6, 2005
    Posts:
    20
    Likes Received:
    0
    Location:
    Norman, OK
    on mine it was running fine one day, then i filled it up with gas as i was towing my boat out to the lake and it ran absolutely horrible and i couldnt get over 50 mph, 35 mph going uphill. it continued to run bad until i started getting lower on gas and after i added gas treatment and injector cleaner - then it started to run OK again. on my way home, sans boat i could hit over 70 mph, although still running choppy. then i filled up with gas and it all went to hell again, although this time i couldn't even hit 35 mph without a boat. i changed plugs and that didn't help any, and i am thinking either clogged injectors or bad fuel pump. i dont know anyone with an auto tap for the Jimmy to plug into the computer so i have no idea what to think.
     
  10. az ranger

    az ranger 1/2 ton status

    Joined:
    May 9, 2004
    Posts:
    139
    Likes Received:
    0
    Location:
    Safford AZ
    I am close to taking it to the shop, I have never taken it in before, but I dont wanna spend more money on a fuel pressure tester or vacume gauge,etting and no one I know has what I need. I am getting frustrated.
     
  11. NateInChandler

    NateInChandler 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    418
    Likes Received:
    0
    Location:
    Chandler, AZ
    Take it to Arizona TPI, They did wonders for my TBI and i never had to look back, Its located on hacienda drive off of University and mcklintock in tempe.. ask for Joe and tell him nate from Tri City Transmissions sent ya.nate
     
  12. supersize75k5

    supersize75k5 OrganDonorRacing.com

    Joined:
    Feb 3, 2004
    Posts:
    8,832
    Likes Received:
    4
    Location:
    gilbert az
    is this your dd?

    if not I have a fuel pressure tester loaned out but I can can get it back also I live in gilbert, ill have to dig for my vaccume gauge but I have one one as well. I went round and round with a jeep last year and had to incure the cost of the testers as well as parts so I know how ya feel:o

    call me tuesday if you like,

    480-228-3218

    shawn
     
  13. az ranger

    az ranger 1/2 ton status

    Joined:
    May 9, 2004
    Posts:
    139
    Likes Received:
    0
    Location:
    Safford AZ

    no not my DD I drive it a couple times a week
    thanks for the offer I found a buddy in town who has the FP tester so I ll try that tommorrow and go from there.
     
  14. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
    I've had the same two codes but mine is a TBI swap. All new sensors and VSS. I'd be interested to know what they tell you.
     

Share This Page