Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

350 to 454tbi swap problem

Discussion in 'The Garage' started by jeepthrillz, Dec 29, 2006.

  1. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    hello people , I really need some tech help on my 1 t0n 91 chevy crew , hopefully some one can shed some light this way cuz its very dark here,
    This is the senario got a 1 ton chevy crew 350 tbi 4L80E 205 , swaped in a 454 tbi every thing fit nicely except for the iac and the tps , the 454 is out of a 1989 sub 2wd , the engine fired up at the first crank every thing is runing nice at idel and at acceleration i park ,the problem begines when i put it in drive and start drive away and try to accelerate the motor starts to stumble and hesitate and puts as you try to wot it it just doesnot speed up,i checked just about every thing that i could think of , i used a pcm from a 91 dually with a 454 and 2wd 4L 80E it starts right up i also tried my stock 350 pcm w/ 4l60e but i does the same thing , I was told by tom at turbo city i orange county that i could use either or they both would work, does someone have any suggestions on what may be my prob, thanx :( :( :( :(
     
    Last edited: Dec 29, 2006
  2. desertrat67

    desertrat67 Hawk Driver

    Joined:
    Jul 5, 2001
    Posts:
    3,982
    Likes Received:
    74
    Location:
    Dumfries, VA
    are the fuel puimps/pump in good condition? Fuel filter plugged? My 90 had a similar problem whe nthe fuel pumps went out and I used an inline pump. The inline wasn't pulling enough fuel through the in tanks and it would starve the engine.
     
  3. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    454 350 problrm

    yes the fuel pump is in good shape it ran my 350 perfect, and ive changed out to a new fuel filter .:( :( :(
     
  4. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    I'm assuming you have addressed these issues first?
     
  5. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    of course i did ! i ckd all the basics 1st timming set at 4deg disc the brn wire at the driver side fire wall, fuel press. is 9- 13 lb new ac delco spark plugs new ceramic jacobs wires, the only thing i have not changed is the injectors but they were runing perfect when i repalaced the motor,
     
  6. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Are you using the 454 injectors, if not the 350 injectors aren't enough fuel.
     
  7. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    IM using every thing that the motor came with,
     
  8. nvrenuf

    nvrenuf NONE shall pass! Premium Member

    Joined:
    Jan 7, 2002
    Posts:
    13,075
    Likes Received:
    245
    Location:
    Mobile, Al.
    Did you see the 454 run yourself?
     
  9. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    yes i drove both the sub w the 454 and my crew w thhe 350 they both ran perfect , i just put brand new injectors in it today from gm for 200 each w my discount and it still runs the same stutters at wide open throttle and hesitates , any other suggestions, :crazy:
     
  10. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Swap MAP sensors. They are the same but maybe you have a bad one.
     
  11. 54inches

    54inches 1/2 ton status

    Joined:
    Feb 9, 2004
    Posts:
    1,535
    Likes Received:
    0
    Location:
    Houston, Texas
    Go to binderbulletin.org and there is a tech area with a TON of info to troubleshoot these problems....
     
  12. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  13. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    ill swap it right now
     
  14. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    changing the map sensor did not make a diff. still runs the same , i disconected the 02 sensor and it ran a little better, it idols smoother too,
     
  15. 54inches

    54inches 1/2 ton status

    Joined:
    Feb 9, 2004
    Posts:
    1,535
    Likes Received:
    0
    Location:
    Houston, Texas
    Did you try the guys over at binderbulletin.org? Like I said there is a TBI forum and that guy knows his stuff!

    Are all of the sensors new?

    Do you have the VSS hooked up correctly or at all?
     
  16. jeepthrillz

    jeepthrillz Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    9
    Likes Received:
    0
    Location:
    california
    Ok im just ready to give up on this 454 crap and swap in 03 cummings diesel with the 2wd tranny and a divorce 205,,,
    Ok can some body shed some light on this project pls . ive just changed about every thing that i can think of on this truck .
    new spark plugs new jacobs wires new coil new pick up , new dist cap and rotor new gm injectors and tb gaskets new o2 sensor new map iac tps , fuel press. is at a steady 10-14 lbs new fuel filter , 2 different pcm {350tbi w/4l80 and 454tbi w/ 4l80e turbo city fuel press, reg, all the sensors are within specs ,:mad: speed sensor is hooked up didnt even touched it when i swaped motors, my 60k miled 350 ran better than this 80k miled 454,o it has good compression,
     
  17. 54inches

    54inches 1/2 ton status

    Joined:
    Feb 9, 2004
    Posts:
    1,535
    Likes Received:
    0
    Location:
    Houston, Texas
     

Share This Page