Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4 wheel disc probs....

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 86jimbo, Mar 17, 2006.

  1. 86jimbo

    86jimbo Registered Member

    Joined:
    Sep 8, 2005
    Posts:
    59
    Likes Received:
    0
    Location:
    Arkansas
    I put 4 wheel discs on my blazer when I built the 1 ton. No 1/2 ton brake system would work very good, so I put in hydroboost. It works pretty good, but I notices that the front brakes are wearing and the back is not at all. Can that be that Im still running a stock prop valve? If yes, what should I get to resolve my problem? Thanks.
     
  2. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    Get an adjustable prop valve so you can control front to back pressure.
     
  3. ryanstrucking

    ryanstrucking 1/2 ton status GMOTM Winner

    Joined:
    Feb 2, 2003
    Posts:
    182
    Likes Received:
    0
    Location:
    Calgary AB Canada
    When I added rear disc brakes to my blazer (dana 70) the breaks worked like crap, so.....I removed the factory porportioning valve and replaced it with a willwood porportioninig valve (to control the rear pressure). Works very good now. Hope this helps.....
    Ryan
     

Share This Page