Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4 wheel drive don't work

Discussion in '1983-2005 S-Series models' started by davester8022, Dec 5, 2002.

  1. davester8022

    davester8022 Registered Member

    Joined:
    Dec 5, 2002
    Posts:
    5
    Likes Received:
    0
    Location:
    Stationed in Missouri but hail from Idaho
    4 wheel drive don\'t work

    I have a '91 GMC sonoma and my light didn't come on down by my 4x4 shifter. So I figured it was the vacuum switch as ive had to replace it about 3 times in the past, so i replaced it yesterday and it still wont come on. I jacked the truck up put it in gear in 4 high and the drive shaft from the transfercase was spinning but the cv axles were not. So the problem looks to be in the differential. What could be the problem? Thanks for any help. Dave
     
  2. s10350power

    s10350power Registered Member

    Joined:
    Aug 6, 2002
    Posts:
    16
    Likes Received:
    0
    Location:
    Maryland
    Re: 4 wheel drive don\'t work

    I just had the same problem with my 88 s10 blazer but my hub indicator inside the truck light up meaning they are "locked" But I have no 4 wheel drive, front drive shaft spins but no 4x4 I was told to buy the posi-lok on 4wheelparts.com by a respected mechanic in town a good friend of mine as well when i get it and put it on ill tell u if it works for me /forums/images/graemlins/crazy.gif
     

Share This Page