Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4l60 shift problem - need advice

Discussion in 'The Garage' started by Rolled, Apr 30, 2007.

  1. Rolled

    Rolled 1/2 ton status

    Joined:
    Jun 16, 2002
    Posts:
    683
    Likes Received:
    0
    Location:
    Anchorage, Alaska
    I have a 4l60 that will not shift in drive or overdrive.

    It will shift gears if I manually shift them. Just not on its own...

    What could that be?

    I just bought the truck so I don't know the history on it.
     
  2. pin_it_to_win_it

    pin_it_to_win_it Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    94
    Likes Received:
    0
    Location:
    centeral coast california
    Sounds like what happened to a frend of mines beater truck he was reving it out in nutral and shifting in to drive to get the holeshot when he tried to race people on pavement:haha: . tranny needs rebuilt:doah:
     
  3. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    TV cable set ok? Level ok? Have you serviced the trans? Is the linkage actually pushing the selector through D and OD?
     
  4. Rolled

    Rolled 1/2 ton status

    Joined:
    Jun 16, 2002
    Posts:
    683
    Likes Received:
    0
    Location:
    Anchorage, Alaska
    Its a 1995 4l60E, BTW. I forgot to mention it was electronic.

    I just put a new filter, fluid, and gasket on when I rebuilt the motor. I never drove the rig before I did the motor. Motor was blown when I bought it.


    No TV (I think) cause its electronic. I goes ito all gears via the shifter.

    It just won't shift by itself.

    Does anybody have a link to a diagnostic chart for these? I'd like to start narrowing down the problem before I yank it out.

    Thanks
     
  5. SkysTheLimit

    SkysTheLimit 1/2 ton status

    Joined:
    May 23, 2003
    Posts:
    530
    Likes Received:
    0
    Location:
    Tampa, FL
    I don't know how to tell but is it a manual valve body?
     
  6. BoondocK5

    BoondocK5 1 ton status Author

    Joined:
    May 13, 2006
    Posts:
    10,035
    Likes Received:
    63
    Location:
    Salt Lake City, Utah
    I have the complete rebuild instructions and diagrams but if you've never done one, I would not suggest doing it
     
  7. Rolled

    Rolled 1/2 ton status

    Joined:
    Jun 16, 2002
    Posts:
    683
    Likes Received:
    0
    Location:
    Anchorage, Alaska
    I would like any info you may have. You can email me at

    gorathcredits @ yahoo.com


    I have rebuilt th400. Never a 700r4/4l60



    I am oping I can trouble shoot it and fix it instead of rebuild it. Its electronically shifted so it may be a simple servo replacement. I just don't know much about these trans and would really like to find an online bible to diagnosing them. I figured CK5 was the first place to start since the wealth of knowledge here is unprecedented.


    This is in a 1995 Jimmy, BTW.
     
  8. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    Well that changes my answer a bit then! I'll have a dig around for info but I've not messed with those.
     
  9. Rolled

    Rolled 1/2 ton status

    Joined:
    Jun 16, 2002
    Posts:
    683
    Likes Received:
    0
    Location:
    Anchorage, Alaska
    I think I found the problem. I have not fixed it yet but feel pretty good about it.

    I think its the VSS. Ma speedo does not work and the ABS light is on. I found a few references to my upshift problem that indicates the VSS is to blame... Its an easy fix so I'll try that out later on.


    Here is a good diagnostic chart I found. Maybe somebody can use it in the future...


    Here is the link to it incase it goes dead.


    http://impalassforum.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=4;t=006666;p=
     
  10. jjlaughner

    jjlaughner 3/4 ton status

    Joined:
    Jan 12, 2001
    Posts:
    7,406
    Likes Received:
    0
    Location:
    Indiana
    Awesome... been reading around, I'm having the

    " 11. No 1st or 4th available; trans shifts 2nd to 3rd by itself in D or OD : ShiftA solenoid failed. Easy fix in the pan. Or a wiring problem from PCM to trans.. or PCM."

    issue currently. Planning on calling around tomorrow for the shiftA solenoid, not looking forward to dropping the exhaust to get to my trans pan though... :doah:
     
  11. jjlaughner

    jjlaughner 3/4 ton status

    Joined:
    Jan 12, 2001
    Posts:
    7,406
    Likes Received:
    0
    Location:
    Indiana
    Pan dropped out without removing anything more than the t-case skid plate (ZR2). Had to do some research the Shift Solenoid A and Solenoid B are the same type. The one on the drivers side is A and the passengers side is B. I only replaced A. Having do it again I might opt for a shift kit. I done a couple searches to find out which Solenoid was which and there is a ton of sites for upgrade parts and performance parts that are basically the same price as dealer items. I called three places on prices, $41 (local dealer), $30 (local Napa), $23 (dealer 20 miles away). Never hurts to call around!

    Trucks seems to run normal again!
     

Share This Page