Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4L80E stuck in 2nd gear. Why?

Discussion in 'The Garage' started by y5mgisi, Oct 3, 2009.

  1. y5mgisi

    y5mgisi 1 ton status Premium Member

    Joined:
    Aug 11, 2002
    Messages:
    17,120
    Likes Received:
    186
    Location:
    Portland Oregon
    My dad has a 96 chevy one ton van. tbi 350 and a 4l80e. He says its been acting up for a while, but now he has only 2nd gear and reverse:eek1: Any ideas? I know there are solenoids in there but why would they not function properly?
     
  2. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Messages:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Throw a scanner on it and check the tranny codes. The computer may tell you what is wrong.
    Might have a bad shift, or pressure solenoid. like anyother electrical thing they just wear out after time. Or sometimes the screens in them get blocked with crud if the fluid is not changed regularly.
     
  3. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Messages:
    24,804
    Likes Received:
    147
    Location:
    horseheads , ny 14845
    sounds like fail safe mode. 2nd and reverse only.

    you need to find and fix the problem first.
     
  4. y5mgisi

    y5mgisi 1 ton status Premium Member

    Joined:
    Aug 11, 2002
    Messages:
    17,120
    Likes Received:
    186
    Location:
    Portland Oregon
    Can i use the paperclip trick to find tranny trouble codes?
     
  5. Keitha

    Keitha 1/2 ton status Premium Member

    Joined:
    Oct 13, 2008
    Messages:
    920
    Likes Received:
    2
    Location:
    Costa Mesa, CA
    I think you can find the codes w/ the paperclip trick. Try it out.
     
  6. MTNMIKE

    MTNMIKE 1/2 ton status

    Joined:
    Jan 3, 2007
    Messages:
    106
    Likes Received:
    0
    Location:
    RENO, NV
    96' Is that obd1, or obd2 did you check the fluid and any connections to the tranny ?

    OBD 2 uses a scanning computer plugs in under dash on driverside. I believe obd2 came out around 96' or 97'.

    I had a friend with similar problems(not a 4l80e), he changed the fluid and filter and it worked fine (it was a newer dodge not a diesel).

    good luck!

    Mike
     
  7. y5mgisi

    y5mgisi 1 ton status Premium Member

    Joined:
    Aug 11, 2002
    Messages:
    17,120
    Likes Received:
    186
    Location:
    Portland Oregon
    TTT, I have heard people say this can be caused by the VSS. True? Sorry for asking these questions without having answers. He is supposed to be dropping it off at my house in the next couple weeks so i can fix it and im just trying to plan/think ahead.
     
  8. y5mgisi

    y5mgisi 1 ton status Premium Member

    Joined:
    Aug 11, 2002
    Messages:
    17,120
    Likes Received:
    186
    Location:
    Portland Oregon
  9. Robbie6987

    Robbie6987 1/2 ton status

    Joined:
    Jul 16, 2002
    Messages:
    111
    Likes Received:
    0
    Location:
    killeen TX
    Same thing mine did when the vss went out, big electical plug on the r/h side can work loose also and cause the same probs. Also it wont always throw a code but u can get it checked for free at autozone if u dont have a scan tool.
     
  10. dbabicky

    dbabicky 1/2 ton status

    Joined:
    Sep 17, 2005
    Messages:
    1,597
    Likes Received:
    0
    Location:
    Wisconsin
    1996 is OBD II
     
  11. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Messages:
    9,458
    Likes Received:
    2
    Location:
    Olympia/Lacey, Washington
    wow, a year later? been driving in 2nd gear the whole time ?? :D :tongue1:
     

Share This Page