Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4wd Engaged light comes on during long drive?

Discussion in 'The Garage' started by sled_dog, Jan 29, 2005.

  1. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    Alright if I drive my burb for a long time at a constant fast speed the 4wd engaged light on the dash comes on. Its bothers me cause all I can do is smack the shifter to make sure its really in 2HI and hope the tcase isn't somehow engaged. This is a 241 Tcase behind an SM465. Last time it happened ot me was when I moved out here to Blairsville, I drove the turnpike the whole way doing 65MPH. It came on dimly at first, then full on bright, then dimly went out and cycled like that for a time. Today it just came on dimly enough you could read the words but not like it does when it is really in 4 wheel. I almost think the fluid gets hot and somehow sets off the switch but that about doesn't make sense. The light works fine when I put it in 4 hi or lo. Any thoughts? I haven't climbed under it and checked the wiring because until yesterday my road and driveway were covered in slush.
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Perhaps the shifter jiggles enough to make contact? Does it go off if you shift the t-case into 4 then back to 2?
     
  3. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,170
    Likes Received:
    1,377
    Location:
    E-town baby!
    I don't think it has anything to do with the T-case, I think it could be a ground problem. Of all things, my truck does the same thing, except there isn't a single wire hooked up to my SM 465 or 205 shifter. I didn't even know my truck had a 4x4 engaged light until it came on (dimly at first) about a week ago.

    I have some other dash cluster problems, which makes me suspect a poor ground though. I have no dash lights, and the fuel gauge is pegged as 'full' as the needle will go.

    I'm thinking the 4x4 engaged light is a ground interupt circuit like the dome lights. There is constant power to the light, but ground is only provided when the shifter ground a switch. In my case it must be robbing ground from somewhere else.

    Does everything else work on the guage cluster on your 'Burb?

    Rene
     
  4. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    yeah my dome light is on all the time now so I have ground issues there. It blinks on and off and if I kick the kick panel it goes off, sometimes.
     
  5. chrisb420

    chrisb420 1/2 ton status

    Joined:
    Aug 6, 2004
    Posts:
    652
    Likes Received:
    0
    Location:
    Binghamton, NY
    4wd coming on

    i had a problem like this in 2000 on my zr2 blazer after driving for awhile i would see the light come on it was still under warranty at the time and the chevy dealer found an open wire that was grounding against the engine block.
     

Share This Page