Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4X4 keeps engaging?

Discussion in 'The Garage' started by lowdend, Feb 9, 2007.

  1. lowdend

    lowdend Registered Member

    Joined:
    Jul 23, 2006
    Posts:
    8
    Likes Received:
    0
    Location:
    Surrey
    I'm thinking that my front end is slightly engaging. Problem is, when I hit the brakes I start to hear a kind of grinding noise coming from the front axle. I have an 87 K5 Blazer with a 4" lift and 33's. I've tried numerous times to engage and dis-engage the 4X4, but it'll still make the noise. Has anyone else had this problem? Does it sound like I'm on the right track with the front end engaging? Any help is appreciated. Thanks
     
  2. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    Have you checked the condition of your brake pads?
     
  3. Chevy305

    Chevy305 6 Lug 14bsf Status Premium Member GMOTM Winner

    Joined:
    Jan 23, 2006
    Posts:
    11,228
    Likes Received:
    485
    Location:
    New Hampshire
    sounds more like brake problems to me...
     
  4. lowdend

    lowdend Registered Member

    Joined:
    Jul 23, 2006
    Posts:
    8
    Likes Received:
    0
    Location:
    Surrey
    Yeah I thought that it might be the brakes so I took the wheels off and checked, but I still have probably 80% left.
     

Share This Page