Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

4x4 light

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 84k5, Feb 21, 2001.

  1. 84k5

    84k5 1/2 ton status

    Joined:
    May 13, 2000
    Posts:
    2,949
    Likes Received:
    0
    Location:
    Dublin, CA
    This thing came on while I was going down the freeway at 65 mph or so. Made no noise and nothing broke. I stopped, backed up, and it went out. I have a 84k5 with a 10 bolt and the stock auto hubs. Is something going wrong with the hubs or is this just some wierd thing?

    Brian
    <A target="_blank" HREF=http://84k5.coloradok5.com>http://84k5.coloradok5.com</A>
     
  2. Whassup

    Whassup 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    140
    Likes Received:
    0
    Location:
    Wyoming, USA
    It's most likely a short in the wiring to the light, or youre bulb is going out, i've seen them start coming on and off before they died.

    "There's NO replacement for displacement!"
     
  3. dawson444

    dawson444 1/2 ton status

    Joined:
    Jul 5, 2000
    Posts:
    1,034
    Likes Received:
    0
    Location:
    Raleigh, NC
    Did you get your K5 back?

    Dawson
    Raleigh, NC

    88 K5, 4" lift, 33" BFG muds
     
  4. Smitty

    Smitty 1/2 ton status

    Joined:
    Sep 1, 2000
    Posts:
    999
    Likes Received:
    1
    Location:
    Crestview, FL
    Must be nice to have a fancy light to tell you when you're in FWD! Think I'd guess at a short too.

    Smitty
     

Share This Page