Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

6.2 fast idle sensor question

Discussion in 'The Garage' started by cucvzee, May 22, 2005.

  1. cucvzee

    cucvzee Newbie

    Joined:
    May 22, 2005
    Posts:
    1
    Likes Received:
    0
    Location:
    NJ
    Hello,

    I recently got an '84 military 6.2 diesel blazer and ran into this problem....... The fast idle solenoid fails to energize at cold startup.......I traced the problem to what the manual i got with the truck referrs to as a temp switch located toward the rear of the block on the passenger side (its a small screw in sensor wth two prongs-- one gets power from the ign switch, the other goes to the fast idle solenoid)..... According to the book i have, this thing is supposed to remain closed when cold and open at a set temp thereby cutting power to the fast idle solenoid. My problem is that when i tried to get this part from a local supplier they looked at me like i had a third eye when i referred to it as a "fast idle switch" -- A local mechanic told me that this thing is most likely a #TX47 sensor but the parts store referrs to that as a glow plug sensor. Does anyone have any input as to what the correct name and part number for this little gizmo is?

    thanks

    Zee
     
  2. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,180
    Likes Received:
    1,388
    Location:
    E-town baby!
    I believe that is called the "Temp inhibit" switch, and I think it prevents the GP's from cycling when the truck is warm too. Might want to try the Stealership for that item.

    Rene
     
  3. DieselDan

    DieselDan 1/2 ton status

    Joined:
    Jan 27, 2001
    Posts:
    1,056
    Likes Received:
    0
    Location:
    Vermont
    Try temp switch for the HPCA (high pressure cold advance) on the injection pump. It controls that in conjunction with the high idle solenoid. Did you get the parts TM also? It should list a manufacturer's part number (that NAPA can cross reference).
     
  4. u2slow

    u2slow 1/2 ton status

    Joined:
    May 9, 2001
    Posts:
    2,217
    Likes Received:
    0
    Location:
    BC Canada
    You're giving it 1/4 throttle when you start it right? If you don't, it won't engage.
     

Share This Page