Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

6.5 diesel problem

Discussion in 'The Garage' started by the general, Jul 14, 2006.

  1. the general

    the general Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    96
    Likes Received:
    0
    Location:
    prinsenbeek(the Netherlands)
    guys i have a problem with my 86" 6.5 diesel(a new engine) in my k30 pick up(the 6.2 is replaced) i saw that one return pipe was broken of from a nuzzle(on the right the second) ive replaced it with a new one (Lucas) and now my engine is rough idling(shaking) that was not!! there before. so i think its the new nuzzle what do you guys think?:bow:
     
  2. DieselDan

    DieselDan 1/2 ton status

    Joined:
    Jan 27, 2001
    Posts:
    1,056
    Likes Received:
    0
    Location:
    Vermont
    You replaced an injector? (nuzzle??) Sounds like you've got air in the line. With the engine running, crack open the injector hard line where it screws into the top of the injector. Fuel should leak out, then tighten it. Drive the truck for a few miles.

    If this doesn't solve your problem I'ld be afraid your (new)injector is bad or you managed to get dirt into the injector/line.
     
  3. the general

    the general Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    96
    Likes Received:
    0
    Location:
    prinsenbeek(the Netherlands)
    yes ive replaced a injector and there,s no air in the line(s) the engine is very clean(its a new one) so i yhink its the new injector thats fault,does this happen more or what?
     
  4. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,624
    Likes Received:
    1,380
    Location:
    Jersey Shore
    It certainly sounds like air or dirt in the system... How did you bleed the system?
     
  5. the general

    the general Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    96
    Likes Received:
    0
    Location:
    prinsenbeek(the Netherlands)
    guys ive found it!!!(yep its onbelieveble) it was the line itselves there was a very very very minor crack on the iinside of it right on the edge(on the side of the block) replaced it with a new one and now it drives like hell,thanks for the help !!!

    Patrick, The Netherlands.
     

Share This Page