Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

700 blowing radio fuse

Discussion in 'The Garage' started by ct85k10, Apr 20, 2006.

  1. ct85k10

    ct85k10 1/2 ton status

    Joined:
    Oct 25, 2005
    Posts:
    121
    Likes Received:
    0
    Location:
    Charlotte, NC
    short version:
    1984 transam 305 and 700r4 in 85 k10
    blows radio fuse unless trans is unplugged at trans or fuse panel
    all new electrical in trans pan


    long version:
    about a year and a half a go I swapped the 305 and 700 from a 84 transam (with only 22k miles) into my 85 k10 after that the radio fuse would blow as soon as I turn on the ignition. 1 year later(I just un plugged it under the dash so the radio would work) I finally get around to trying to fix it turns out that the transmission is on the same fuse ok the lockup solenoid is bad (I thought) I cut the solenoid lose still blows the fuse [​IMG]so I un plug the pressure switch(I think that’s what is called) and it doesn’t blow the fuse so off to Napa the have no clue what this are (this is Friday after noon)so Monday I go to the dealership 2 days later I get the part and put it in still blowing the fuse so 5 days and 100$ later I decided to put the pan back on and not worry about it.

    6 months later it’s still running fine but it kind of bugs me that it’s not right

    sorry for the long post any one got any ideas what is causing this
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    I wouldn't be surprised if the trans you got is wired internally FOR the switches differently. I know there were at least a couple variations for GM trans on how they were wired, I'd bet that's your problem.

    Hoping some tranny guys chime in.
     
  3. reptilianman

    reptilianman Registered Member

    Joined:
    Apr 9, 2006
    Posts:
    12
    Likes Received:
    0
    Location:
    clarkston , michigan
    On tranny swaps ive seen the wire harness to the trans get pinched between the engine and trans.
     

Share This Page