Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

72 blazer lift kit

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by chulisohombre, May 8, 2002.

  1. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    i just put a pro comp lift on my blazer.my rear axle now rests about 2 inches forward to the front of the wheel opening.why is this.can anyone help?
     
  2. Triaged

    Triaged 1/2 ton status

    Joined:
    Feb 21, 2001
    Posts:
    3,808
    Likes Received:
    0
    Location:
    CA (LA/OC area)
    Did you put the springs on the right sides? Front or rear?
    The factory springs AFAIK have the center pin in the center of the spring. When you get aftermarket springs they sometimes move the center pin to make it look right.

    The part # that is on the spring should be on the front side of the spring.
     
  3. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    i thought i had them on right because of the way the weges were on the bottom of the spring.are they supposed to have the smaller side torward the front for pinion angles?when i took the lift blocks off the smaller side was to the front so i thought that was how to install the springs.i measured them it has 26 inches to the center pin torward the back and 25 to the front.would it be better to switch the direction of the srpings around?
     
  4. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    by the way they were just the rear springs i replaced.the front was already done but are4 sagging a little so eventually those will get done too.
     
  5. Triaged

    Triaged 1/2 ton status

    Joined:
    Feb 21, 2001
    Posts:
    3,808
    Likes Received:
    0
    Location:
    CA (LA/OC area)
    Sounds like you need to turn them around. You could also turn the degree shims to make the driveshaft angles work. Maybe they got put on wrong at the factory?
     
  6. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    sounds about right.thanx for the help.
     
  7. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,141
    Likes Received:
    14
    Location:
    Bangor,Pa
    sounds about right.thanx for the help.i'll try that and see what happens
     

Share This Page