Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

73 k5 w/ loud clicking noise near flexplat and converter? Help!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Blaze`, Mar 27, 2004.

  1. Blaze`

    Blaze` Registered Member

    Joined:
    Mar 12, 2002
    Posts:
    54
    Likes Received:
    0
    Location:
    Austin, TX
    Trying to figure out why my truck is making a horrible clicking noise near the flexplate/torque converter area. It is LOUD at idle and now I am hearing it while driving.

    Any thoughts? Ideas? Please help!

    Thanks,

    Donovan
     
  2. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    [ QUOTE ]
    Trying to figure out why my truck is making a horrible clicking noise near the flexplate/torque converter area. It is LOUD at idle and now I am hearing it while driving.

    Any thoughts? Ideas? Please help!

    Thanks,

    Donovan

    [/ QUOTE ]

    Yep
    First and most probable is the flexplate broke.
    Change it now before you get stranded.
    It also could be what happened to me once where the tabs of the pump that go into the Torque converter shear off and the remaining edges click like that.
    Same thing fix it soon.
    To replace the flexplate you could just unbolt the tranny and slide it back a little and take out the flexplate, it's tight but can be done.
    /forums/images/graemlins/thumb.gif
     
  3. 4xrick

    4xrick 1/2 ton status

    Joined:
    Sep 14, 2003
    Posts:
    1,102
    Likes Received:
    0
    Location:
    kirkland Wa
    yup its the flex plate replaced way to many of those things always starts out a little tick then gets louder and one time boom its broke and you are stranded fix it asap
     
  4. BigRed89

    BigRed89 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    223
    Likes Received:
    0
    Location:
    Los Angeles, CA
    As stated above, Flexplate. Encountered this same thing on a friend's Sub. In his case it was a crack that started between the bolt holes where the flexplate mounts to the crank.
     

Share This Page