Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

83 Jimmy electrical prob

Discussion in 'The Garage' started by Strahan, Feb 11, 2004.

  1. Strahan

    Strahan 1/2 ton status

    Dec 4, 2001
    Likes Received:
    Yoe, PA
    Howdy. I've been talking about my problem in the other forum (http://coloradok5.com/forums/showfl...5237/page/0/view/collapsed/sb/5/o/all/fpart/1) figured I'd crosspost just in case someone that reads here has input.

    Last weekend my 83 Jimmy K5 headlights got real dim driving home. Checked the dash volt meter, it was in the red down by 8 volts. Figured bad alternator. Next day bought an alternator and installed it. Also replaced battery with a new one. Still had the prob. Went back to store I got it from, it tested bad. They threw a new one on and tested it, it passed. Volt meter shown high 12 volts idle. Drove it around, seemed stable. Let it sit overnight, it still started the next day and looked good. Figured all is well. Girlfriend came home tonite with the truck and said it's back in the red. Went out and it was just above 8 volts again. Shut off the headlights, it went back up to low 12s.

    Any idea what I should try now? It has a new alternator and battery. Thanks.
  2. cybrfire

    cybrfire 1 ton status Vendor GMOTM Winner

    Dec 15, 2002
    Likes Received:
    I'd be checking the grounding wires for the headlights. Make sure all the contacts are tight and clean.

Share This Page