Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

'83 K5 350 no spark

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Sample, Oct 25, 2002.

  1. Sample

    Sample 1/2 ton status

    Joined:
    Oct 15, 2002
    Posts:
    536
    Likes Received:
    0
    Location:
    Apache Junction, AZ
    \'83 K5 350 no spark

    This is the HEI. Can someone give me a rundown on the ignition system? I am not getting any spark at the plugs.

    Chris
     
  2. bobsurf

    bobsurf 1/2 ton status

    Joined:
    Jun 26, 2001
    Posts:
    410
    Likes Received:
    0
    Location:
    San Marcos, CA
    Re: \'83 K5 350 no spark

    See if this post helps.
     
  3. bigblock454

    bigblock454 Clack Clack Clack Premium Member

    Joined:
    Jun 18, 2002
    Posts:
    546
    Likes Received:
    16
    Location:
    Terre Haute IN
    Re: \'83 K5 350 no spark

    First make sure you have 12 volts at the distributor (when the ignition is on). That is the thickest wire of the ones there. If you have 12 volts then remove the coil and ignition module and take them to autozone, they can test them for you. Desides the obvious (cap, rotor, wires, rotor bushing) the only thing left is to make sure the CAM is turning. Look in the distributor hole while someone turns it over. If you don't have 12volts with the iginition on then either you have blown a fuse (is that even fused??) a grounded wire or bad ignition switch.

    Hope that helps.
     

Share This Page