Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

84 Blazer no spark

Discussion in 'The Garage' started by SptCoupe73, Aug 13, 2005.

  1. SptCoupe73

    SptCoupe73 Newbie

    Joined:
    Aug 13, 2005
    Posts:
    1
    Likes Received:
    0
    Location:
    PA
    Hi yall I have a overly beat 84 k5 with 243k on the original 305 that will not start, it is not getting spark, i first replaced the HEI module, then the coil (3 times), and then the whole distributor (with a brand new coil, module, cap and rotor) out of a 86 GMC van with 85k but the engine had a reman sticker from 1998. I just cant figure this out i thought the motor was blown at first because the motor seamed seized but i let it set a week and it started turning again (dont ask me this thing has hated me since day one). and after my dad bitching about this one (he hates 73-87's for some reason) i pulled it out of the yard with my frontier (and ripped off the back bumper yaay me) It now kinda seems like it gets spark then loses it. Also this thing is a electrical nightmare (hit the right turn signals the left front ONLY blinks then hit the left and the two rear and front sometimes blink, shift it into 4wd and then the interior light fuse blows, my 90 had same problem with that though). but i do wanna get it running cuz it is unstoppable off road any help will be appreciated
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    When you aren't getting spark, are you getting 12V on the coil wire?
     
  3. SptCoupe73

    SptCoupe73 Newbie

    Joined:
    Aug 13, 2005
    Posts:
    1
    Likes Received:
    0
    Location:
    PA
    Ya there is 12v on the coil power. but it still will not fire up.
     

Share This Page