Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

87' 350 TBI intermintent check engine light and misses

Discussion in 'The Garage' started by fast-eagle, Jul 28, 2005.

  1. fast-eagle

    fast-eagle Newbie

    Joined:
    Jul 28, 2005
    Posts:
    2
    Likes Received:
    0
    Location:
    Tomball, Texas
    I have a 87' Chevy K5 Blazer w/ 350 TBI. While driving it I have had the check engine light come on, followed by engine miss firing. This occurs out of the blue and usually lasts 30 seconds to a minute each time. The rest of the time it runs just fine. It seems to be pointing to a elctronic module failure of sorts. Anyone have any experience with this kind of problem before? Any help would be greatly appreciated. :1zhelp:
     
  2. tx_sub

    tx_sub 1/2 ton status

    Joined:
    Mar 5, 2004
    Posts:
    548
    Likes Received:
    0
    Location:
    Denton, TEXAS
    check to see if it is throwing any codes. that may point you in the right direction.
     
  3. mikayak390

    mikayak390 Registered Member

    Joined:
    Mar 3, 2005
    Posts:
    70
    Likes Received:
    0
    Location:
    NJ
    My guess is the egr code and the computer ignition control. I have the same problem. My Egr is only a year old, I keep meening to check it out, but its currently running and its hot out.

    Just wondering does yours happen more often in OD or when you get on the gas hard?

    If you figure it out first please post. I will do the same.
     
  4. fast-eagle

    fast-eagle Newbie

    Joined:
    Jul 28, 2005
    Posts:
    2
    Likes Received:
    0
    Location:
    Tomball, Texas
    I will have to see if they are hard codes that will stay in the system, or if they are soft ones that are lost when the condition goes away.
     
  5. btolenti

    btolenti 1/2 ton status

    Joined:
    Sep 28, 2003
    Posts:
    644
    Likes Received:
    0
    Location:
    Gilroy, CA
    I had a similar problem in my truck. It has the full computer controlled carb. It turned out to be a bad ignition module. Changed it, and have had no problems since! :waytogo:
     
  6. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Any trouble code is stored. Soft codes are not lost when the CEL goes out.
    So check your codes.
    If there are no trouble codes stored. Then your problem is most likely the distributor module.
     

Share This Page