Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

87 R-30 454 Tbi Need Help:

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by conoverbandit, Jan 15, 2004.

  1. conoverbandit

    conoverbandit 1/2 ton status

    Jan 23, 2002
    Likes Received:
    Conover N.C
    Hey Y'all,

    I got a 87 R-30 crew cab with 454 TBI. When we got it the tbi harness that goes to the top of tbi had burnt pretty good, and I think the gaskets were burnt out (all this thanks to old gas not wanting to burn lol). Anywho, I have replaced the tbi harness, and bottom (flange) gasket, and the gasket inbetween the tbi it's self. It cranks and runs great to me, but when cold it has this really loud "hissing" noise, I thought since I flipped the air cleaner lid upside down the sound was just the air going into tbi, after engine warms up the "hiss" goes away. I have noticed the same problem on my dad's 87 4x4 350 tbi, when cold there's a strange "hissing" noise that comes from inunder the hood, and when engine gets to operating temp. the hiss goes away. I have tried to find the source of this, but like I say it appears to be comming out the top of the air cleaner (upside down) Any one got any ideas? I have looked for a loose vacume line but haven't located any, and also my dad's truck is doing the exact same thing, so if I can figure this out I can fix both of them. Thanks, Y'all,
  2. Thunder

    Thunder 3/4 ton status

    Jul 20, 2000
    Likes Received:
    Northeast Nevada
    Turn the air cleaner lids back over, you wont hear the hiss anymore.. Flipping the lid really doesn't do any good with TBI. The stock system flows plenty of air for TBI. Plus the colder air pulled from the front of the engine makes more power.

Share This Page