Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

87 tbi sputtering on take off....?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bigarmzz, Aug 9, 2006.

  1. bigarmzz

    bigarmzz 1/2 ton status

    Joined:
    Feb 21, 2005
    Posts:
    184
    Likes Received:
    0
    Location:
    elkins, west virginia
    i got a 87 350 tbi that always seems to sputter some on take off from a dead stop...even on idle it seems like it has a slight miss

    i just changed the fuel filter, hoping that was all it was, but its still there...is there anything in the throttle body that could be doing this?..iac, tps, map..etc...???

    thanks:confused:
     
  2. chevyuser74

    chevyuser74 1/2 ton status

    Joined:
    Jun 19, 2006
    Posts:
    1,473
    Likes Received:
    0
    Location:
    Mukwonago, Wi
    is it running to lean or to rich try unpluging ur temperature sensor this will tell the computer that the engine is really cold and will dump lots of fuel in if its the same u know its running rich if it runs good u know its lean
     
  3. bigblue

    bigblue 1/2 ton status

    Joined:
    Dec 6, 2000
    Posts:
    658
    Likes Received:
    0
    Location:
    southern california
    have you replaced your fuel pump yet ? i know my 87 it went out and kinda sputtered for a while before it finally gave out ..
     
  4. bigarmzz

    bigarmzz 1/2 ton status

    Joined:
    Feb 21, 2005
    Posts:
    184
    Likes Received:
    0
    Location:
    elkins, west virginia
    no i havent replaced the pump...its kinda a pricey sucker:doah:
     
  5. loafer

    loafer 1/2 ton status

    Joined:
    Aug 19, 2003
    Posts:
    634
    Likes Received:
    0
    Location:
    Lyman, Maine
    Last in-take fuel pump I changed on my old 88 TBI Blazer cost me about $37.00 at parts store. That was only a year ago or so.

     
  6. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    How about the ignition? Good visual inspection? New plugs/wires? you've ensured the cap and rotor are in good shape?
     

Share This Page