Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

88 TBI starts and dies, then hard to start.

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chevyracing, Mar 5, 2003.

  1. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    88 350 with TBI starts right up, runs for a few minutes then dies. When he tries to restart it it will just crank and crank until he pumps the gas. I thought this is a little wierd because of the TBI.

    This is for my Brother in Law who just moved to Colorado from Iowa. We have not made any adjustments to anything yet. I was wondering if we need to advance the timing a little because of the altitude like you do on a carbed vehicle. This TBI stuff is greek to me.

    Thanks,
    John
     
  2. milspecjimmy

    milspecjimmy 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    901
    Likes Received:
    0
    Location:
    raymond, maine
    fuel filter or pump i would say
     
  3. 90K5Blazer

    90K5Blazer Registered Member

    Joined:
    Jun 10, 2002
    Posts:
    48
    Likes Received:
    0
    Location:
    Dayton, Ohio
    [ QUOTE ]
    fuel filter or pump i would say

    [/ QUOTE ]

    right on!
     
  4. BigRed89

    BigRed89 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    223
    Likes Received:
    0
    Location:
    Los Angeles, CA
    I agree, sounds like it's the fuel filter.
     
  5. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    Sounds like the filter...You don't need to mess with the timing on a TBI, the ESC takes care of that...Just unhook the ESC from the dist and set straight up at 0*...

    Replace the filter and if it still does it, check the fuel pressure...

    Are there any codes in the computer? *could* also be TPS or IAC related, but doubtful...

    I bought on of the Echlin TBI tune-up kits from Napa and it helped a bit too...there are actually two little filters at each injector, and one of mine was clogged pretty bad...

    Chris
     

Share This Page