Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

89 sub still won't start? update

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by eatsjeeps, Dec 9, 2002.

  1. eatsjeeps

    eatsjeeps Registered Member

    Joined:
    Dec 7, 2002
    Posts:
    23
    Likes Received:
    0
    Location:
    Portland Oregon
    89 sub still won\'t start? update

    Well tested all carb Items I could test and it tested ok
    Now we have moved on to NO SPARK or INTERMITENT SPARK.
    from coil.
    If I crank it long enough or often enough I get spark occasionally. But never long enough to start the rig.
    I guess that would explain why I could get it started before by stuffing a screwdriver in carb it wasnot that that was helping but was buying time, and waiting for intermitent spark. any Ideas
    the coil on the Sub and coil in manual are not the same but we have tested the coil to the best of our ability and it seems to be bad. Get infinite reading on high energy
    and low reading low side
     
  2. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: 89 sub still won\'t start? update

    More info please....

    You have an 89 Sub with a CARB??? Not TBI?
     
  3. eatsjeeps

    eatsjeeps Registered Member

    Joined:
    Dec 7, 2002
    Posts:
    23
    Likes Received:
    0
    Location:
    Portland Oregon
    Re: 89 sub still won\'t start? update

    It is TBI
    sorry can't get past old habits
    last one was a 71 LC FJ40 /forums/images/graemlins/laugh.gif
     
  4. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    Re: 89 sub still won\'t start? update

    oh, a little thing that will help also is to fill out your profile as much as possible, others will better be able to help, especially if they might have the same setup as you.
     
  5. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: 89 sub still won\'t start? update

    Do you see the injectors spraying???

    If you do, the coil is most likely bad, if you don't - the ignition module MIGHT be bad.

    Good luck.
     
  6. eatsjeeps

    eatsjeeps Registered Member

    Joined:
    Dec 7, 2002
    Posts:
    23
    Likes Received:
    0
    Location:
    Portland Oregon
    Re: 89 sub still won\'t start?

    yes the injectors are spraying
    we have diagnosed as bad coil.
    I will replace that and post back
    this would be the second coil since I bought it
    hopfully the first one was old and the second one was bad when I bought it. HOPE other wise what would be causing it to eat coils?
    Marty
     
  7. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: 89 sub still won\'t start?

    A bad ground can cause the coil to go out...

    Also the wrong type of coil - but I presume this is a HEI in-cap coil - so not much chance of it being the wrong type.

    Good luck.
     
  8. eatsjeeps

    eatsjeeps Registered Member

    Joined:
    Dec 7, 2002
    Posts:
    23
    Likes Received:
    0
    Location:
    Portland Oregon
    Re: 89 sub still won\'t start?

    ok replaced coil
    got three starts out of it
    so where do I need to start checking for bad ground?
    /forums/images/graemlins/angryfire.gif this is starting to make me want my cruiser back. /forums/images/graemlins/1zhelp.gif
     
  9. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: 89 sub still won\'t start?

    Check the ground on the coil itself. The tin hook looking thing should go to the negative side of the connector to the ground of the coil (one of the four screws that hold the coil on the cap.

    Also check the cap and rotor to make sure the plunger thingy inside the cap didn't break. I had this happen once... REALLY hard to find the problem with this....

    Seems weird that it would start three times.. and then no more.

    Did it run three times or just "kinda' start?

    GOod luck.
     
  10. eatsjeeps

    eatsjeeps Registered Member

    Joined:
    Dec 7, 2002
    Posts:
    23
    Likes Received:
    0
    Location:
    Portland Oregon
    Re: 89 sub still won\'t start?

    First It is running now. /forums/images/graemlins/grin.gif
    Second it is not an in cap coil the coilis located just in front of the distributor, also in checking for bad ground points we found that the rotor was not installed correctly and had worn down some of the plasitc inside the cap, as well as the connection block to the distibuter was loose.
    it is running AGAIN. /forums/images/graemlins/burb.gif
    fires right away and idles smooth.
    Thanks for all your help
    Marty
     
  11. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: 89 sub still won\'t start?

    Excellent.

    Good job on diagnosis.
     

Share This Page