Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

89 suburban vss senor, esc, cruz control

Discussion in 'The Garage' started by gonger, Mar 11, 2006.

  1. gonger

    gonger Registered Member

    Joined:
    Nov 8, 2004
    Posts:
    42
    Likes Received:
    0
    hi all, ive been lurching around this site for awhile and am always able to find the info I need , but this one has me stumped, I just picked up 89 sub, its got ecm code relating to vss sensor and electronic spark control.

    1. so are vss codes associated with the sensor or the vss buffer?

    2. it has cable speedo, and manual says speed sensor should be located behind instrument cluster, so I get back there and all I see is speedo cable going into instrument cluster, no sensor, I do see a sensor on the transfer case up high near shift linkage is this it?

    3. it looks like at sometime it had cruz contol, theres a vaccum switch down near the brake pedal, so when you have your foot on the brake you hear vaccum noise, the cruzcontrol canister up near the tbi has been remove, so can I ditch the vacum switch near the brake pedal?

    any help would be great.
     
  2. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    The VSS should be attached to your speedo - that is the factory setup for a 1989 suburban. There should be a small wire harness leading to a small green box (VSS buffer) within 6 inches of the back of the speedo. If this is not the case someone has swapped it to something else.
     
  3. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,544
    Likes Received:
    540
    Location:
    horseheads , ny 14845
    yep like he said. there will be a single screw that holds the optical light on the back of the speedo to see the speedo movment inside the gauge. and this leeds to the greenish box he said.

    also if no more cruise then remove vac line and just plug it off. no need to remove complet switch.
     
  4. gonger

    gonger Registered Member

    Joined:
    Nov 8, 2004
    Posts:
    42
    Likes Received:
    0
    thanks I have found the greenbox, the truck was painted recently and it looks like it never got hooked back in, now I got the vss hooked back up. theres also a fiber optic cable coming from behind gas guage, does it go somewhere, currently it goes no where, thanks again for the help, the haynes manual just dosnt cover this stuff well.
     
  5. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,544
    Likes Received:
    540
    Location:
    horseheads , ny 14845
    the cable is a light to the cigerete box area.
     
  6. gonger

    gonger Registered Member

    Joined:
    Nov 8, 2004
    Posts:
    42
    Likes Received:
    0
    you guys are awsome.
     
  7. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    i didnt know that ESC was with TBI, i though it was only with the carb engines


    interesting
     
  8. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    I'm sure the Electronic Spark Control is a bit different on the TBI than carb application, because of the interface with the dizzy.
     
  9. gonger

    gonger Registered Member

    Joined:
    Nov 8, 2004
    Posts:
    42
    Likes Received:
    0
    I think I got things worked out today, got the vss hooked back up, couple of plug wires were burned to headers, repaced cap/rotor/plugs, so it seems to running on all 8 now, no more service engine light. I hope, I think the dead cylinders were letting gas get into oil, oil was all thined out comming out the exhaust, what mess. I figure out why the overdrive wasnt working, its got a t400 in it. this might hamper my plans to put my 4.88 geared axles in it.
     
  10. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    You don't need overdrive to run 4.88s. Mine does fine with the TH350 trans and 4.88s. Tops out around 50, but thats temporary as new, bigger tires will give me a better top end!
     
  11. gonger

    gonger Registered Member

    Joined:
    Nov 8, 2004
    Posts:
    42
    Likes Received:
    0
    50 wont cut it is arizona traffic, so time for some 44's.
     

Share This Page