Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

94 suburban

Discussion in 'The Garage' started by dheavychevy38, Apr 2, 2003.

  1. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    got a 94 chevy subrban with a tbi 350 it has 70,000 miles
    the problem is when you accel at about a 1/4 throttle it boggs out if you nail it it will go away any ideas oh yeah it is also loseing antifreeze no puddles and it isn't in the oil
     
  2. MudNurI

    MudNurI 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,113
    Likes Received:
    0
    Location:
    VT
    The mileage right on that thing??? got rid of my 94 in 99- with 87K.........Cant help ya though. other than - check the normal stuff... fuel fliter, plugs, wires etc...
     
  3. COCHEV

    COCHEV 1/2 ton status

    Joined:
    Jul 9, 2002
    Posts:
    4,055
    Likes Received:
    2
    Location:
    Washougal WA
    the bogging could be a number of things. start with the simple stuff- check the base timing, check for vacum leaks, check to see if the egr is working properly. also, test your o2 and cts sensors for correct voltage.

    as for the coolent i've heard tbi motors are notorious for bad manifold to head gaskets. i have this problem on the wifes 93 burb but i have been too lazy to change it /forums/images/graemlins/tongue.gif
     

Share This Page