Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

94 tbi ???s

Discussion in 'The Garage' started by Afireinside, Jan 22, 2005.

  1. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    I just bought a 1994 3500 4x4 4 door.I'm not a newbie to chevy just the F.I. I have a few questions.#1 Is there any way to make my back door windows go all the way down(there big like a suburban not tahoe).and what would make the rear right window(power)not work.#2 I constantly have high idle so I took the front driver vacume port from the tbi and ran it right to the modulator on the throttle arm and it lowered it to like 900 rpms(still not right).Maybe it's the tbi gasket?
    #3 When the truck warms up it starts to get a popping sound from the exhaust at idle(like a miss)and loses power at the same time,the engine power is good when it's cold.
    #4 I also have a charging prob. with no lights or anything on it's allright but if you turn on the lights you lose power.So today I put in an auto zone alt. and still no change.I have the big wire from the batt. to the starter then I have about a 10 ga.from the alt. to the + post on the batt.and then I have about an 8 ga. from the + on the batt. that seems to power the whole truck.Does this seem right.Thanks for all the help

    #5.What is the IAC.thanks
     
  2. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    Sorry it's a 454.Thanks
     
  3. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    Does that have a side post battery if so check the connections they are know for corroding really bad and someting falling out of the battery.Have had that happen a couple of times the truck will run great turn on light or turn signal and the gauge will just drop.

    Those also like to suck intake and tbi base gaskets.

    The power one when the last time it had a tune up had the same problem on a 94 burb with 350 the coil was junk.

    The iac is a Idle Air Control Valve. I think it is located on teh front of the tbi unit.
     
  4. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    Thanks thats part of what i'm thinking because it does have side terminals,I just bought marine terminals and all the parts to change it so ill try in the mourning.Thanks
     
  5. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    Just becareful on some of the older batteries when you go to remove the wire and lug the post comes with out of the battery and then you have acid all over.
     
  6. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    There o kay I had them off today to swap the Alt.thanks and BTDT.
     
  7. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    a way to check for the vaccum leaks is to spray some carb clean in the area and if it idles down you have a leak.
     
  8. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    Thanks I already tried that around the front and side sides of the tbi no change ill try the back later when I got light Thanks again
     
  9. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    Anyone ttt:xmas:
     
  10. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    I fixed the back window today I needed a new motor.Now that rear window will go all the way down so how do I make the other.Any help with the other stuff.Thanks all
     
  11. Afireinside

    Afireinside Registered Member

    Joined:
    Jan 22, 2005
    Posts:
    61
    Likes Received:
    0
    Location:
    Aurora Colorado
    To update a little#1.Got all the windows working I replaced the motor in one and the power lock on the other had come loose and was binding w/ the window, fixed that.
    #2.Bypassing the vacume line that goes to the modulator(454 specific)caused a code 36 so I hooked it back up.So I still have high idle but no codes.Could a faulty stat. cause this? Any ideas?
    #3.Just replaced the plugs and wires and drove to the gas station seemed to have cured it but it didnt get completely warm so i'm goin on a drive in a litlle bit i'll report back.
    #4.Replaced all the batt.wires and all seems good.
    Thanks for all the help.
     

Share This Page