Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

94 vortec cpi problem

Discussion in '1983-2005 S-Series models' started by ed1507, Dec 23, 2005.

  1. ed1507

    ed1507 Registered Member

    Joined:
    Jan 25, 2003
    Posts:
    70
    Likes Received:
    0
    Location:
    indiana
    heres the problem it cuts out after it gets warm and just looses all power kinda like to much fuel or not enough o2 is new map sencer is new tps is new fuel lines in cpi replaced fuel pressure reg replaced computer 3mo old
    any more ideas:(
     
  2. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    have you checked the engines compression and how do your plugs look
     
  3. 70BlazerX2

    70BlazerX2 1/2 ton status

    Joined:
    Aug 2, 2009
    Posts:
    198
    Likes Received:
    0
    Location:
    Greeneville Tennessee
    egr vavle have something stuck in it holding the valve open? They have an aftermarket gasket with a screen in it to stop carbon getting in there. This may be it.
     
  4. retroblazer

    retroblazer 1/2 ton status Premium Member

    Joined:
    Nov 30, 2003
    Posts:
    282
    Likes Received:
    156
    Location:
    Gustine
    The magnetic pickup in the distrib can also go bad.
     
  5. throttleissues

    throttleissues 1/2 ton status GMOTM Winner

    Joined:
    Jul 15, 2007
    Posts:
    4,700
    Likes Received:
    0
    Location:
    Kern County
    You guys realize this is from 2005, right?:rolleyes: The OP hasn't even logged in since 12/05.:doah:
     

Share This Page