Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

95 grand cherokee, trans went bang, slipping

Discussion in 'Other Rides' started by R72K5, Nov 30, 2004.

  1. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    95 grand cherokee, 4.0L 4 speed auto trans probably the 42RE , 4x4, 95k original miles, always garaged, trans went bang in gear, slipping now, fluid dark

    is this a factory fault ?
    i heard theres a TSB about the trans cooler lines flow being partially restricted and a fix kit for them, so maybe theres a overheating burnup issue with these ?
    also i heard theres a TSB on a drum or drum seal failure in these too


    what happened ?
    whats the fix ? is there a TSB on this ? if so then what parts are involved

    i know of a 93 or 94 GC with a godo tranny in a yard in springfield, would this be better route ?


    any way to prevent this from happening again ?



    thanks
     
  2. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    it is actually the 42RH/RE tranny, the cherokee got the AW4.

    its hard to tell, but sounds like something broke and its not getting the pressure required. my books show no common problems with that particular tranny. /forums/images/graemlins/dunno.gif
     

Share This Page