Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

98 tahoe wont start security light on

Discussion in 'The Garage' started by wufido, Nov 5, 2005.

  1. wufido

    wufido Newbie

    Joined:
    Nov 5, 2005
    Posts:
    2
    Likes Received:
    0
    Location:
    Aurora
    I got a 98Tahoe LT 4X4, a couple days ago i left my dome lights on, (security lights had been on for a week or so already). and my battery died completely dead so I bought a new one. But Now the truck wont start, it'll crank and turn on for a second or two, and then it shuts off. my security light doesn't blink it just stays on. I need to know what I can try before I spend some serious money in the Dealer. Thanx
     
  2. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    Is it possible that you forgot to reattach a small wire to the battery? Or that a wire going into the main fuse box, from the battery, is broken or corroded? I went to help a guy with the exact same problem after replacing the batery, and 1 wire that went to the fusebox had dropped out of sight and was not attached and the truck would just turn over, but the headlights worked. Nothing powered by the inside fusebox would work. Do your radio and interior lights work? Have you checked for blown fuses? I know it's a stretch, but stranger things have happened to fuses. Also be sure to wiggle any body ground wires near the area you were working on.

    **EDIT** there may be something that has to be reset for the security system**EDIT**
     
  3. gm500hprat

    gm500hprat 1/2 ton status

    Joined:
    Feb 28, 2005
    Posts:
    196
    Likes Received:
    0
    Location:
    anaheim, ca
    Your truck has a posslock module that connects to the inside of the ignitin solenoid. I just went through this a year ago. There are to pieces to the device its impossible to figure out which one it is so just get both replaced. I think it was about 200 for both pieces you have to go to the dealer for it. I had the same problem in my 99 burb. It drove me crazy what happens is when you start your truck the passlock module sends a start code to the ecm and that then sends a signal to the injectors to open. The module goes fault and it sends an incorrect password to the ecu and thats why you get the security light.
     
  4. wufido

    wufido Newbie

    Joined:
    Nov 5, 2005
    Posts:
    2
    Likes Received:
    0
    Location:
    Aurora
    reply

    everything else works in the truck, it just wont start, it cranks and turns on for like a sec or two. then it dies. I think its the passlock module the one GM500hpwrrat is talking about, thats probly my first guess, i'll check it out. because the Fuel Pump is working. and it seems like when it starts the fuel cuts out and thats when the truck turns off. Thanx, more suggestions would be helpful. THanx again
     
  5. gm500hprat

    gm500hprat 1/2 ton status

    Joined:
    Feb 28, 2005
    Posts:
    196
    Likes Received:
    0
    Location:
    anaheim, ca
    Your symptoms are the ones i had exactly to a tee. I tried first replacing my fuel filter and then the fuse for the fuel pump module. My truck would start for 2 seconds and then die i would try it a kazillion times in a row with no luck. So I took off my air filter and sprayed fuel directly into the ad throttlebody and the truck would runn as long as i gave it fuel so i knew it was a fuel issue. My buddy has a shop and he runs the alldata software program and thats how i found out about the passlock module. I had called the dealership and they had no idea what was wrong with my truck they had me trying all sorts of crazy things. Anyways after I had a pretty goo idea what it was after researching it i bought the parts and my buddy put them in and i have not had a problem since. The software also said that the security error would reset after 10 minutes and in some instances the truck would start bypassing the error code but not on all the vehicles, i guess i had on of the luck ones because my truck did this in the snow with my wife and two kids. And being from so cal, were pretty stupid when it comes to dealing with cold weather conditions. Anyways hope this helps...Art
     
  6. BozoWise

    BozoWise 1/2 ton status

    Joined:
    Mar 28, 2002
    Posts:
    1,224
    Likes Received:
    0
    Location:
    Lubbock, TX
    Before replacing the passlock system. Disconnect the battery for 1hr, then reconnect and do not try to start for 30min. Then try one more time. Sometimes the passlock systems will show an error and not let the vehicle start until a 30min down time has been clocked. Common symptoms of poor remote start installs we deal with at work.
     
  7. 73k10sub

    73k10sub 1/2 ton status

    Joined:
    Jul 23, 2001
    Posts:
    223
    Likes Received:
    0
    Location:
    Tulsa, OK
    Starts and dies

    I had the same problem on my '98 C2500 and '99 Yukon. The mechanic (not at a dealership), and I am loosely quoting, said "the vehicle thinks it is being hot wired or otherwise tampered with and does not recognize the ignition key and it shuts off the fuel supply after it starts". My security light in neither vehicle came on and neither vehicle would put out a code. So, in short it was a security problem. We ended up sending both vehicles to a programmer who "de-programmed" this feature out and we have had no further problems. No new parts were required. Apparently this situation was not limited to pickups and SUVs because he had a car doing the same thing before they finally figured it out. The dealers, at that time, had no clue or would not tell if they did.
    Hope this helps.
     
  8. neverendingproject

    neverendingproject 1/2 ton status

    Joined:
    Jul 24, 2005
    Posts:
    1,637
    Likes Received:
    0
    Location:
    Tulsa, OK
    I dont know about the 98 but if it it like the 95 and has the little thing that you put under the dash to get it to start,(this sometimes fouls up and you cant get it to start) you can remove that whole system and get the truck to wrok that way. let me know if that is your situation and I will tell you how to get rid of it.
     

Share This Page