Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

A/C belt vibration

Discussion in 'The Garage' started by danny7139, Jul 6, 2006.

  1. danny7139

    danny7139 1/2 ton status

    Joined:
    Jan 27, 2005
    Posts:
    227
    Likes Received:
    0
    Location:
    florida
    Just got the a/c fixed on the blazer during the rebuild and when the a/c is engaged the belt vibrates pretty bad. It blows good and smooths out at higher rpm's. I've tighted the clutch bolt with still no affect and the belt seems good and not to tight. Could it have something to do with the power steering pump?

    Thanks
     
  2. danny7139

    danny7139 1/2 ton status

    Joined:
    Jan 27, 2005
    Posts:
    227
    Likes Received:
    0
    Location:
    florida
  3. kp texan

    kp texan 1/2 ton status

    Joined:
    Sep 8, 2003
    Posts:
    211
    Likes Received:
    0
    Location:
    Corpus Christi, TX
    What you're experiencing is normal. Since you have an '85 K5 I'm assuming that you have a V-belt setup rather than a serpentine. There has been a TSB issued on the compressor pulleys up to the '88 model year which is the last year of V-belt accessories. Mine has the exact same issue with a properly tightened belt. The part number for the high inertia pulley to fix this issue is p/n 6552402. Unfortunately, this is a discontinued part and only 2 dealers in Texas had one and they wanted $115 for the pulley. I decided to leave it the way it is because thats too much money to fix something thats just a little annoying and causes no harm.

    -Wes
     

Share This Page