Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

A/C switch problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by kihlj, Jul 8, 2002.

  1. kihlj

    kihlj Registered Member

    Joined:
    Oct 16, 2001
    Posts:
    38
    Likes Received:
    0
    Location:
    Dallas, TX
    I just converted my A/C over to the 134a system and it is blowing cold once again. However, I have noticed that the vents down by the floor (in the center) are blowing no matter which setting I have on the a/c set to. I would think the only time that the bottom should blow is when I have it set to Bi-Level or heater. I have an '89 K5. Is this normal or is something wrong here?

    Thanks in advance for your help.

    Jason
     
  2. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,089
    Likes Received:
    489
    Location:
    Grand Rapids area
    You just have a bad vacuum line or switch. The mode selector switch in the dash controls which flappers get pulled. Either one of these is leaking or the flapper itself is sticking. I don't think there's any way to figure out the problem without tearing into things under the dash.
     
  3. GMMANIAC

    GMMANIAC Registered Member

    Joined:
    May 1, 2002
    Posts:
    53
    Likes Received:
    0
    Location:
    San Antonio, Tx.
    Check the vacuum line in the engine compartment for leaks, it is at the back of intake buy the firewall.
     

Share This Page