Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Ack!!! Need constructive input...UPDATE

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by tRustyK5, Dec 24, 2001.

  1. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    OK, here's the deal. tRusty is normally quite trusty and very seldom does it do odd things. Tonight was a major exception to that.

    I arrived at work and it was running normally, 700 RPM idle, smooth, temp normal, oil pressure normal, alt doing it's thing...I shut it off and went inside to start my shift. At lunch (2 am [​IMG])I decided I'd bring it inside the shop and service my hubs...it's been way too long! I started tRusty up and the first thing I hear is the motor is whining like its got a blower...weird. Also it will not idle. To keep it running it needs to be over 1800 RPM or you have to start feathering the gas to keep it going.

    Once I got it in the shop I checked for disconnected vacum lines...everything was still connected. Checked the choke and it was operating as usual. Snap the throttle and there is a nice squirt of fuel. The carb is an Edelbrock 1406 and is about 2 1/2 years old. Running without the air cleaner the whine seems to be coming from the carb...

    Any ideas? I'm leaning towards part of the idle circuit being clogged or something...

    One other thing...driveability does not improve as it warms up, it ran just as crappy when I got home this morning. Also WOT does not seem to be affected by whatever problem this is. I opened her up on the freeway just to see what it would do and it was normal.

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>

    <P ID="edit"><FONT class="small">Edited by tRustyK5 on 12/27/01 07:34 PM.</FONT></P>
     
  2. Butch

    Butch 1/2 ton status

    Joined:
    Apr 26, 2000
    Posts:
    1,338
    Likes Received:
    0
    Location:
    Austin, TX
    Re: Ack!!! Need constructive input

    Could you have sucked the carb to intake gasket when you cranked it or maybe even the intake to head gasket. When my gasket under the carb went out mine did exactly that. Spray some WD-40 around the base of the carb and see if the motor revs. Also dont know if Edelbrock has a power valve like Holleys do but that will cause that problem in a Holley.

    I thought I was wrong once,
    but I was mistaken
     
  3. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    Re: Ack!!! Need constructive input

    I'm gonna grab some shut-eye and try the WD 40 after lunch...I hadn't considered the carb to intake gasket. I'll let you know what I find.

    Thanks!

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>
    <a target="_blank" href=http://coloradok5.com/gallery/project_T2> tRusty pics...</a>
     
  4. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Re: Ack!!! Need constructive input

    It's telling you that it's time to slap EFI on top of it! [​IMG]

    The only things I own with carbs on them are lawn care implements. [​IMG]

    But the slipped gasket sounds feasible. The "blower whine" that you're hearing could be an oscillating piece of gasket somewhere.

    <font color=black>HarryH3 - '75 K5</font color=black>
    <a target="_blank" href=http://www.angelfire.com/super/ThunderTruck>www.angelfire.com/super/ThunderTruck</a>
    It's a great day to be alive...
     
  5. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Re: Ack!!! Need constructive input

    Sounds like a MAJOR vacuum leak. Like Butch said spray around and see if you have a gasket that failed. I thot maybe your carb may have iced up, from being cold out and a small amount of water turned to ice will clog a jet, but you said it doesnt change when its warmed up and runs fine WOT.

    Betcha never got the hubs serviced did you!?!?! LOL!! [​IMG]

    If ya can't stop.......Smile as you go under! [​IMG]
    PIC of mine from flblazers site<a target="_blank" href=http://www.flblazer.alloffroad.com/photo3.html>
    GO</a>
     
  6. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    Re: Ack!!! Need constructive input

    Yes the Edlebrock FI is looking better and better. Need a big block first [​IMG]
    The gasket does make sense, I did have a look down the throat of the carb thinking something may have got sucked in causing the whine.
    It was an entertaining drive home anyways...feathering the gas to keep it over 1800 RPM made everyone think I wanted to race them light to light.[​IMG]

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>
    <a target="_blank" href=http://coloradok5.com/gallery/project_T2> tRusty pics...</a>
     
  7. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    Re: Ack!!! Need constructive input

    <blockquote><font class="small">In reply to:</font><hr>

    Betcha never got the hubs serviced did you!?!?! LOL!!

    <hr></blockquote>
    How much do you wanna bet?[​IMG] Hell it was in the shop anyways and I wasn't having any luck getting it to run better so I serviced my hubs.[​IMG] The passenger side was pretty gunked up...it was majorly overdue!

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>
    <a target="_blank" href=http://coloradok5.com/gallery/project_T2> tRusty pics...</a>
     
  8. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Re: Ack!!! Need constructive input

    Mmmm, me like-um big block! The cam for my 454 finally shipped! It's supposed to arrive on Friday. [​IMG] An EFI big block does seem like a somewhat radical solution to your problem, but sometimes you just gotta do what ya gotta do! [​IMG]

    <font color=black>HarryH3 - '75 K5</font color=black>
    <a target="_blank" href=http://www.angelfire.com/super/ThunderTruck>www.angelfire.com/super/ThunderTruck</a>
    It's a great day to be alive...
     
  9. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Re: Ack!!! Need constructive input

    Well I guess I was wrong! LOL! I figured you spent your time trying to get it to run right and didnt get to the hubs. I havent opened my hubs up yet. I havent had it anywhere off road, the front shaft isnt in so I havent worried too much about it yet. I dont even know if the front shaft is long enuff. Maybe Ill check that today.

    If ya can't stop.......Smile as you go under! [​IMG]
    PIC of mine from flblazers site<a target="_blank" href=http://www.flblazer.alloffroad.com/photo3.html>
    GO</a>
     
  10. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    Re: Ack!!! Need constructive input

    Don't feel too bad, my Q-jet just up and decides that some times it will idle at about 450RPM, lope like crazy, and run rich. (anything over idle is fine) Of course, its not consistent, not that old of a rebuild, and works perfectly fine about 90% of the time. Yet another reason to go FI, although that comes with its own batch of problems, as does everything : ) Hmm..spend time troubleshooting carb or jsut suck it up until I go TPI, which will, knowing me, take until 2003 to get installed.

    Dorian
    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>www.dorianyeager.com/index2.html</a>
    Why insist on counting when the ring gear has the tooth counts stamped in?
     
  11. wayne

    wayne 3/4 ton status

    Joined:
    Feb 1, 2001
    Posts:
    6,178
    Likes Received:
    0
    Location:
    Carlisle, Pa
    Re: Ack!!! Need constructive input

    I had a similar problem years ago on a truck I had and found a bolt to hold the carb on the intake was loose, I tightened it up and never had a problem after that.

    See <a target="_blank" href=http://coloradok5.com/gallery/Waynes-Toy>Project Mighty Mouse</a> here.
    <font color=blue>Wayne<font color=blue>
    <font color=blue>Happy Trails<font color=blue>
     
  12. Highlander

    Highlander 1/2 ton status

    Joined:
    Nov 25, 2000
    Posts:
    1,204
    Likes Received:
    0
    Location:
    Lakewood Colo
    Re: Ack!!! Need constructive input

    My 83 did something like that one time I looked for a vacume leak at the carb and the two vacume hose's around the carb it wasn't utill I shut it off and was standing by the power brake booster and heard the leak it was the rubber gromit it was a hard leak to find when your looking at just the hose.
    Good luck to you

    Eric

    <a target="_blank" href=http://cethern.tripod.com/erics-home-page-and-other-stuff/>http://cethern.tripod.com/erics-home-page-and-other-stuff/</a>
    AMSOIL Dealer # 529948
    Cethern@interfold.com
     
  13. michaelm

    michaelm 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    872
    Likes Received:
    0
    Re: Ack!!! Need constructive input

    dont use WD40 for that, eww
    use propane like from a plumbers torch, less mess
    like everyone else it sounds like vacuum leak to me
    tighten carb down
     
  14. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: Ack!!! Need constructive input

    Alllllllright!!!! Gonna step up to a big block!!!!! [​IMG]

    All I can say is....aboot time!! [​IMG] You're gonna have some fun with that big motor!! [​IMG]



    I'm not picking my nose...I'm just pointing at my brain!! [​IMG]

    <a target="_blank" href=http://coloradok5.com/gallery/thatK30guy>The K30 Collection</a>
     
  15. 2Dogs

    2Dogs 1/2 ton status Premium Member

    Joined:
    May 4, 2001
    Posts:
    3,470
    Likes Received:
    35
    Location:
    Ca
    Re: Ack!!! Need constructive input

    Yikes - my world is has been rocked!!!!

    We are supposed to ask YOU questions.... LOL

    Dave

    Horn Broken... Watch For Finger.
    <a target="_blank" href=http://coloradok5.com/gallery/Daves-Pics>http://coloradok5.com/gallery/Daves-Pics</a>
     
  16. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Re: Ack!!! Need constructive input

    Yeah it feels kinda strange dont it Dave?!?!

    If ya can't stop.......Smile as you go under! [​IMG]
    PIC of mine from flblazers site<a target="_blank" href=http://www.flblazer.alloffroad.com/photo3.html>
    GO</a>
     
  17. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    Re: Ack!!! Need constructive input

    While I'm asking questions...do you think I could fit 35's under my truck with a 4" lift?[​IMG]

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>
    <a target="_blank" href=http://coloradok5.com/gallery/project_T2> tRusty pics...</a>
     
  18. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    Re: Ack!!! Need constructive input

    LOL!!! You smart ass. I thought you were wanting to run 31's [​IMG] [​IMG]

    Still hoping the GOV'T will ban the use of loud stereos with RAP music. [​IMG]
    <a target="_blank" href=http://www.nashvillek5.freeservers.com>www.nashvillek5.freeservers.com</a>
     
  19. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Re: Ack!!! Need constructive input

    Ive got a deal on getting some vortec heads, will they bolt right on, or do I need a new flux capacitor and spark plug gaps? What about the muffler bearings? Will they work?

    If ya can't stop.......Smile as you go under! [​IMG]
    PIC of mine from flblazers site<a target="_blank" href=http://www.flblazer.alloffroad.com/photo3.html>
    GO</a>
     
  20. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,167
    Likes Received:
    1,365
    Location:
    E-town baby!
    Re: Ack!!! Need constructive input

    I've heard none of those mods work without the correct blinker fluid viscosity index...

    Rene

    <font color=green>Dyslexics of the world...UNTIE!</font color=green>
    <a target="_blank" href=http://coloradok5.com/gallery/project_T2> tRusty pics...</a>
     

Share This Page