Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Aftermarket heater motor?

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by MuddyMudSkipper, Mar 23, 2002.

  1. MuddyMudSkipper

    MuddyMudSkipper Registered Member

    Joined:
    Mar 7, 2002
    Posts:
    49
    Likes Received:
    0
    Location:
    CA
    My heater motor doesn't blow much air. Anyone know of an available upgrade so I can actually defrost my windshield?
    Jeff
     
  2. 69jimmyhendrix

    69jimmyhendrix Registered Member

    Joined:
    Nov 30, 2001
    Posts:
    8
    Likes Received:
    0
    Great question. I have the same problem & wonder if that is just how they come from the factory or if they just degrade. Am having a similar problem with my wiper blade motor too. Hopefully someone in the know will contribute, good luck.....
     
  3. 69K5

    69K5 1/2 ton status

    Joined:
    Nov 10, 2001
    Posts:
    1,544
    Likes Received:
    0
    Location:
    Monroe, LA
    On mine you had to push the slider all the way over and then press hard so it would go the last little bit. it never really turns on until you get to the last half inch. probably just a new fan motor would do it. Once its on it b;lows pretty good.
    sorry i couldnt help more

    nathan
     
  4. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Is the moter that is in there old .
    If so then just get a new one and your set.You could also try cleaning the connections on the motor's electrical just my 2 cents
     

Share This Page