Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Aghhh what now.(PLEASE HELP)***UPDATE***FIXED

Discussion in 'The Garage' started by MTBLAZER89, Mar 30, 2003.

  1. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    I was driving to work this morning and about 150 feet from the parking lot my truck died /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif. It was running great I just did a new EGR, cap and rotor, fuel filter, and plugs. I think it may be my fuel pump. I have spark cause I just checked it. It will start now but it dies immediatley. No trouble codes just 12 over and over. (that is just the dist. reference right). Sorry just ranting all I can do is sit here at work till 3:30 and see it across the street. /forums/images/graemlins/angryfire.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/angryfire.gif

    Ok here's what I did.
    1 I double checked spark pulled plug 1 checks good. /forums/images/graemlins/thumb.gif
    2 must be a fuel problem....like I thought. Pulled off a line (got lots of gas on me...hmmmm have fuel and and spark thats good. /forums/images/graemlins/thumb.gif
    3 Truck won't start.... /forums/images/graemlins/confused.gif
    4 Pulled out plug 2....No spark Plug 1 no spark.. /forums/images/graemlins/1zhelp.gif
    5 Reseated coil wire and truck starts /forums/images/graemlins/thumb.gif idles good, but here is the problem about 30mph in 1st and 55 in 2nd it starts popping and cutting out I am guessing around 3500-4000 RPM's everywhere else runs good. I have no fawking clue still a fuel problem starving for gas at high RPM's??? /forums/images/graemlins/confused.gif /forums/images/graemlins/confused.gif Any thoughts on this???
    -Brian
     
  2. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.

    Just looked at my haynes and it says take it to a dealer to check fuel pump. (I DONT THINK SO) /forums/images/graemlins/angryfire.gif Anybody know how to check it? Can I just pull a line and crank it?
     
  3. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.

    OK if I have to change my fuel pump how hard is this there is about 15 Gal of gas in the tank how much does a stock tbi pump cost all the part stores are closed here, because obviously nobody works on vehicles on Sunday I guess. Any help would be great kinda sranded here. At least I have CK5 though /forums/images/graemlins/cool.gif
     
  4. LKJR

    LKJR 1/2 ton status

    Joined:
    Apr 18, 2000
    Posts:
    2,116
    Likes Received:
    0
    Location:
    Lubbock, Tx
    Re: Aghhh what now.

    PM 90K5 he just did that job a week or so ago. also check www.autozone.com or one of the other parts stores, most have online pricing. you can get an idea of cost that way.
     
  5. purple76pearl

    purple76pearl 1/2 ton status

    Joined:
    Jan 13, 2003
    Posts:
    450
    Likes Received:
    0
    Location:
    missouri
    Re: Aghhh what now.

    i had that prob with a 94 i had
    here is what i done
    take the ful line going in the to filter, plug it off
    take the filter off (on the frame rail) pul it out and see if you can blow through it
    if not replace it
    if that dont work then it might be the fuel pump
    but could aslo be an injector, hope its not they arent cheap
    thats my 2 cents /forums/images/graemlins/k5.gif
     
  6. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.

    39.99 at autozone
     
  7. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.

    Anyone Anyone?
    /forums/images/graemlins/1zhelp.gif
     
  8. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Re: Aghhh what now.(PLEASE HELP)***UPDATE***

    when it dies while you are driving, look at the exhaust when it starts back up...if its black, then its probably a spark issue. you can have someon crank it over while you look at the injectors to see if they are spraying. also, if when it dies, let it turn off...if it smells strongly of gas under the hood - might need to take off air claner - then its a spark problem.
     
  9. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Re: Aghhh what now.

    damn les....a week ago? your bad sense of time must explain the payment on those tires taking 6 months
     
  10. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.(PLEASE HELP)***UPDATE***

    Injectors seem to be spraying good. So I guess its the fuel pump. Its almost out of gas now too so thats good. Guess I'll do that this week. I'll keep everyone updated.

    -Brian /forums/images/graemlins/k5.gif
     
  11. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.(PLEASE HELP)***UPDATE***

    Well it hasn't died again so that is good. I am trying to run all the gas out of it before a fuel pump (if that is what it is). Any RPM's above 3500 it surges really bad, and pops a little bit. It continues to do this until I let off or it shifts gears then its ok. Anybody have any thoughts or ideas.....similar problems? Please help. Thanks
    -Brian
     
  12. KrebsATM02

    KrebsATM02 1/2 ton status

    Joined:
    Mar 21, 2000
    Posts:
    553
    Likes Received:
    0
    Location:
    College Station, Texas
    Re: Aghhh what now.(PLEASE HELP)***UPDATE***

    If the injectors are spraying good it's not the fuel pump. Fuel pumps usually either work, or don't. First replace your fuel filter, this can never hurt. Might be some kind of pressure regulator problem on the TBI.
     
  13. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Re: Aghhh what now.(PLEASE HELP)***UPDATE***

    Where is the pressure regulator? I have already done the filter. Another thing I forgot to add is the problem does not exist unless the engine is under load. I can hold it at 4000 RPM in park and it runs smooth. I think it may be an emissions problem does anybody know of a component that may cause this.

    -Brian
     
  14. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Fawking vacuum leak.........
    /forums/images/graemlins/rotfl.gif /forums/images/graemlins/rotfl.gif
     

Share This Page