Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Already a problem on my new '91...*FIXED*

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Burbinator, Oct 3, 2001.

  1. Burbinator

    Burbinator 1/2 ton status

    Joined:
    Sep 14, 2001
    Posts:
    898
    Likes Received:
    0
    Location:
    Tempe, Arizona
    Already a problem on my new \'91...*FIXED*

    Well, my new '91 2500 has developed a problem in the 48 hours I've had it. I put it in 4H or 4L and I get this rapid clicking sound when I take off from a stop from the front. I'm fairly sure it's those damn auto hubs, but I wanted someone to affirm that's the problem. I have a new set of Superwinch manuals waiting to be installed this weekend so I can ditch those autos.

    - Alan

    '91 2500 Suburban Silverado 4X4
    '82 K10 Suburban Silverado

    Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut!
     
  2. kpanza

    kpanza 1/2 ton status

    Joined:
    Dec 8, 2000
    Posts:
    1,579
    Likes Received:
    0
    Location:
    Lake Forest, Orange County, California
    Re: Already a problem on my \'91...

    Yeah, sounds like another auto hub biting the big one...mine made the same kind of sound when it broke. Does it also make the clicking on corners? Mine did that also...
     
  3. Burbinator

    Burbinator 1/2 ton status

    Joined:
    Sep 14, 2001
    Posts:
    898
    Likes Received:
    0
    Location:
    Tempe, Arizona
    Re: Already a problem on my \'91...

    I assume you mean clicking on corners while in 2WD. Nope, not yet, but it will probably start now that I said that...

    - Alan

    '91 2500 Suburban Silverado 4X4
    '82 K10 Suburban Silverado

    Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut!
     
  4. Mr.Chevy4x4

    Mr.Chevy4x4 1/2 ton status

    Joined:
    Jun 16, 2000
    Posts:
    1,932
    Likes Received:
    0
    Location:
    Sims, NC
    Re: Already a problem on my \'91...

    Yep, sounds like the auto hubs to me. Those things are such crap. That is always the first thing that I replace. I have a set if someone is crazy enough to want to run them.

    '85 K5 : Run it til it breaks, then fix it and go again!
     
  5. Burbinator

    Burbinator 1/2 ton status

    Joined:
    Sep 14, 2001
    Posts:
    898
    Likes Received:
    0
    Location:
    Tempe, Arizona
    Re: Already a problem on my \'91...

    Well, now I have an evening project replacing them with manuals...good thing, considering I'm in the doghouse!

    - Alan

    '91 2500 Suburban Silverado 4X4
    '82 K10 Suburban Silverado

    Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut!
     
  6. Burbinator

    Burbinator 1/2 ton status

    Joined:
    Sep 14, 2001
    Posts:
    898
    Likes Received:
    0
    Location:
    Tempe, Arizona
    Re: Already a problem on my \'91...

    I replaced my auto hubs last night with Superwinch manuals. Problem solved. Not only do they work great, they match the truck (blue)! LOL!

    - Alan

    '91 2500 Suburban Silverado 4X4
    '82 K10 Suburban Silverado (FOR SALE!)

    Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut!
     
  7. kpanza

    kpanza 1/2 ton status

    Joined:
    Dec 8, 2000
    Posts:
    1,579
    Likes Received:
    0
    Location:
    Lake Forest, Orange County, California
    Re: Already a problem on my \'91...

    That's great! I personally think that everyone who still has the crappy auto-hubs is wise to just swap them out before they break, because they will!
     

Share This Page