Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Alternator, 15V!!!

Discussion in 'The Garage' started by JHG, Oct 22, 2003.

  1. JHG

    JHG 1/2 ton status

    Joined:
    Jul 28, 2002
    Posts:
    129
    Likes Received:
    0
    Location:
    Iceland
    I started my K5 today and finally everythings seems to be in order....I think.

    I installed a Volt gauge from Autometer, and got the alternator repaired at the same time (after a engine fire). Now the gauge shows 15V!

    I alwais thought it should be between 13.8-14.2V.

    Is it alright or should I worry?

    Nonni
     
  2. chulisohombre

    chulisohombre 1/2 ton status

    Joined:
    Apr 11, 2002
    Posts:
    4,137
    Likes Received:
    14
    Location:
    Bangor,Pa
    15 volts is high.it will overload your battery and probably have a meltdown or overflow the fluids.ive heard of batteries exploding but no first hand experience.my alternator runs at about 14 flat at idle.
     
  3. burbBoy

    burbBoy 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    358
    Likes Received:
    0
    Location:
    WI
    Get a multimeter and check it at the battery to be sure the gauge is right.
     
  4. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
    yeah, double check the gauge. Hopefully its just the gauge and you can take it back or maybe the regulator is gone?
     

Share This Page