Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Alternator/Battery Question

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by CarolinaBogger, Jan 17, 2002.

  1. CarolinaBogger

    CarolinaBogger Registered Member

    Joined:
    Apr 17, 2000
    Posts:
    86
    Likes Received:
    0
    Location:
    Boone, NC
    My truck keeps quitin. I jumpstart my truck and the volts will go up to about 13. After a couple of mins while driving, the volts go all the way down and the engine will shutoff. A couple people have told me that if it was the alternator, then the truck should not stop running, it just won't start after i turn it off. However, the battery is only about 6 months old and the people at Advance Auto tested it and said it will hold a charge. Anyone have any advice? It is a computer-controlled '89. Thanks yall

    <font color=green>"I'm old enough to know better, but I'm still to young to care!"</font color=green>
     
  2. scavenger

    scavenger 1/2 ton status

    Joined:
    Mar 31, 2000
    Posts:
    111
    Likes Received:
    0
    Location:
    Southern Wisconsin
    If the battery is good I would suspect a problem with the charging system. Check the alternator belt, atlernator connections and battery cables. If all appears well with these items it may be new alternator time. I believe a vehicle will stop running when the battery no longer has enough juice left to power the ignition system.
     
  3. Thumper

    Thumper 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,582
    Likes Received:
    0
    Location:
    Alberta Canada
    I suspect your truck has a built in voltage sensor that shuts it down at a preset level. If the battery has been drained totally a few times, you may end up replacing both the alt and battery.
    Do you get the charge light on?

    Mike


    <font color=blue>Thumper
    85 Fullsize Jimmy
    [​IMG]
    <font color=red>Aint Skeered!! </font color=red>
     
  4. CarolinaBogger

    CarolinaBogger Registered Member

    Joined:
    Apr 17, 2000
    Posts:
    86
    Likes Received:
    0
    Location:
    Boone, NC
    No lights come on. When it dies, it feels kinda like it running out of gas. It kinda sputters and hesitates for a couple of secs, then quits. I checked the belts and alt connections and all look ok, so i guess it is time for a new alt if my truck does have a voltage sensor. Thanks for the info guys.

    <font color=green>"I'm old enough to know better, but I'm still to young to care!"</font color=green>
     

Share This Page