Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

And just when i thought i found the last bit of mud .......

Discussion in 'Pacific Region' started by LiftedAssDodge, Apr 26, 2002.

  1. LiftedAssDodge

    LiftedAssDodge 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    412
    Likes Received:
    0
    Location:
    East Bay Area, ca
    ..... i pull out the dipstick and find more, im thinking that mud in the oil is kinda bad and all, so im changin my oil tomorrow, yeah cause umm that stuff is supposed to be on the outside
     
  2. gokartergo

    gokartergo 3/4 ton status Staff Member Moderator

    Joined:
    Dec 2, 2000
    Posts:
    5,855
    Likes Received:
    0
    Location:
    Hollister, CA
    I found it inside my dist...Know I now why it was running so bad...LOL
     
  3. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Well I am still finding it from the last time there ( um jan 12 2002 ) does that count...mike
     
  4. Priest

    Priest Registered Member

    Joined:
    Apr 22, 2002
    Posts:
    95
    Likes Received:
    0
    Location:
    Tracy, CA
    Trust me...you only think you found the last of it. I'm still finding mud from last Nov./Dec. You will be finding mud for the next 6 months minimum.
     
  5. LiftedAssDodge

    LiftedAssDodge 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    412
    Likes Received:
    0
    Location:
    East Bay Area, ca
    yeah i dont doubt that
     
  6. Gold Rush

    Gold Rush 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,498
    Likes Received:
    0
    Oh yeah well I took my motor apart today and had mud in the cylinders. Also the headers had mud in the bottom. The passenger side was half full of mud!!!!!!!!!! Drained the transmission and found mud in the pan. Funny thing when I took the T-Case apart found no mud in there. Did I also mention the motor was frozen and had to pull it with the torque converter still attached. What a pain in the @ss.


    David
     

Share This Page