Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Another electrical problem... UGH I HATE ELECTRICAL PROBLEMS

Discussion in 'Pacific Region' started by Topdown, Jul 3, 2004.

  1. Topdown

    Topdown 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    2,598
    Likes Received:
    0
    Location:
    Vancouver, Washington, U.S.A
    Ok... I go away to Detroit for a trip, the blazer sits for 4 weeks... I get in, fire up drive into town, no brake lights.

    I have turn signals, emergency flashers, tail lamps, etc... but no brake lights. I replaced the brake light switch (at the pedal) still no lights. I have checked and there is power at the switch and it appears to be working appropriately but still no brake lights. No juice at the back end of the truck, I cant even tell that there is juice at the firewall... I HATE electrical issues.

    Thoughts anyone?
     
  2. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    Check every since ground you can find in the brake circuit. Sounds like you just have a bad ground to me.
     
  3. JDBlazer454

    JDBlazer454 1/2 ton status

    Joined:
    Feb 27, 2002
    Posts:
    951
    Likes Received:
    0
    Location:
    Vancouver, Wa
    Whenever I lost brake lights on any of my Blazers it always seemed to be the wire had rubbed itself through where its routed through the frame near the rear bumper. Check your connections at plug ins and anywhere it maybe routed through frame or anything that might wear it thin. Also check power at random back to the tail lights.

    If you need any help just yell I think I could pry Jeff away from his busy schedule to help /forums/images/graemlins/histerical.gif
     
  4. mudslinger97116

    mudslinger97116 1/2 ton status

    Joined:
    Mar 13, 2003
    Posts:
    315
    Likes Received:
    0
    Location:
    F.G.OREGON
    i feel for you topdown,i have been fighting the same problem in my blazer theres a post in the first gen. forum that might give you some more ideas.
     
  5. surpip

    surpip 1 ton status

    Joined:
    Apr 7, 2004
    Posts:
    10,877
    Likes Received:
    0
    Location:
    sacramento ca
    the same thing just happened to my MINI that thing has so many eletrical gremlins its not funny /forums/images/graemlins/dunno.gif
     
  6. smprider112

    smprider112 1/2 ton status

    Joined:
    May 1, 2004
    Posts:
    624
    Likes Received:
    0
    Location:
    Beaverton,Oregon
    check all the way under the frame to the bumper...Mine did that too, but with just the tail lights and one of the wires got severed some how.
     
  7. ntaj*ep

    ntaj*ep 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    3,248
    Likes Received:
    1
    Location:
    Evergreen state
    Theres a connection behind the rear bumper more to the drivers side in the body under the tailgate. Its a 4 pin I think if its plugged in un plug it and look at the pins. Make sure they aren't corroded from sitting. clean them off and see what happens. You can also use that as a testing point.
     
  8. JDBlazer454

    JDBlazer454 1/2 ton status

    Joined:
    Feb 27, 2002
    Posts:
    951
    Likes Received:
    0
    Location:
    Vancouver, Wa
    I saw you yesterday cruisin it so I take it its fixed?
     
  9. Topdown

    Topdown 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    2,598
    Likes Received:
    0
    Location:
    Vancouver, Washington, U.S.A
    nope, not fixed, but i needed to get to lowes to get the parts to fix the CAI on the Vue... /forums/images/graemlins/whistling.gif
     
  10. JDBlazer454

    JDBlazer454 1/2 ton status

    Joined:
    Feb 27, 2002
    Posts:
    951
    Likes Received:
    0
    Location:
    Vancouver, Wa
    /forums/images/graemlins/grin.gif I have done that /forums/images/graemlins/whistling.gif Get the attitude hey go ahead and try to hit me you will be the one hurtin /forums/images/graemlins/histerical.gif
     

Share This Page