Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Another electrical problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by joez, Jun 14, 2005.

  1. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    Well, it started raining a little bit ago on my drive home, so i went to turn on my headlights. When i pull the switch all the way back for the headlights, the driver side turn signal indicator lights up and stays light up. It is dimmer than when turn signals are on, but its still on. So i turn just the parking lights on, and it goes off. I get home and decide to check everything. everything in the back works as it should, headlights on or off. But not the front.

    When just the parking lights are on, everything is normal. Turn signals work fine up front, both front and side markers. Turn the headlights on and it goes to crap. The driver side headlight is VERY dim, the high beams filiment is lit, but not enough to produce any real light, and the parking light in the grill is so dim you can hardy see it in the daylight. Turn on the left turn signal, and the parking light alternates with the headlight and high beam, again very dim. Since its raining out, i cant really go poke arround right now, so i figured id see if anyone here has had any similar problems. I almost have a sinking feeling its the dash switch, but i dont know. This sound like it could be a ground issue, i know that these trucks do weird things with bad grounds sometimes.
     
  2. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    Problem solved, i found a ground wire that i had accidentally broken when installing my new, larger batteries.
     

Share This Page